Support » Fixing WordPress » unable to upload media on Windows host- path conflict?

  • Dan_P


    Hi. I just installed vrs. 3.4.2 fresh on a Windows hosting site- no plug-ins. I tried to upload media when creating my first page and got the message:

    “IMG_5698.jpg” has failed to upload due to an error
    Unable to create directory wp-content/uploads/2012/19. Is its parent directory writable by the server?

    …which I thought to be strange for a Windows hosted application. i.e. the forward slashes in the message and the question about permissions.

    Any help is appreciated. I am on

Viewing 6 replies - 1 through 6 (of 6 total)
  • Chris Olbekson


    Level 12 Bug Squasher & Forum Moderator

    The IIS USER needs write permissions to the file system for uploads to work. Not being an expert with Windows hosting I would suggest opening a ticket with GoDaddy.



    Thanks…. I asked a Tech Support person there. WP is a 3rd party product, and they don’t know that much about it, it turns out.

    Is the ‘/’s in the error msg just a leftover from Linux… I hope(?) I am thinking that WP would not seriously try to make dirs with ‘/’s in Window paths, would it?



    Thanks for that.

    I see what you are saying about an IIS USER. Created a new GoDaddy FTP user and pw – using the WordPress user id listed in ‘Users’. Tested fine w/FileZilla.

    It didn’t help with the problem, however. Same error msg appears.



    F.Y.I: My wp-config.php file settings (for Windows):

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘rtng’);

    /** MySQL database username */
    define(‘DB_USER’, ‘rtng’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘a password is here’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘’); – from Web Hosting | Launch | MySQL | Manage via phpMyAdmin | Server:

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);



    If I add:


    from the GoDaddy Server Details window | Absolute Hosting Path, to field:

    Settings | Medit | Uploading Files | Store uploads in this folder, with ‘Organize my uploads into month-and year-based folders’ checkbox cleared…

    a message appears:

    “The uploaded file could not be moved to D:\Hosting\9849076\html\wp-content\uploads”

    So it looks like whatever permissions issue there was has since disappeared. But it’s still not working right.

    Is it just -my- WordPress Windows version that has an upload media problem?


    Go Daddy


    Go Daddy Support

    We could look at your information on this end, but would need you to submit a ticket (if you haven’t already)

    Include all of the details in the ticket and you can reply back here with your ticket number so I could take a look.

    Is there a reason you’re running WordPress on a Windows hosting platform instead of Linux? Just as a rule, WordPress runs much better on Linux and oftentimes, issues are resolved by moving operating systems. However, if there is a need to be on Windows, I’d still like to help you troubleshoot this issue.


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘unable to upload media on Windows host- path conflict?’ is closed to new replies.