Support » Fixing WordPress » Unable to upload images ("Unable to create directory" error)

  • christopher.eleven


    Friday evening I upgrade my WordPress installation to 3.0.1. Before this, there were no problems with image uploading at all. I have my uploads set to be categorized by year and month. Today, when attempting to upload an image, I received the following error message:

    Unable to create directory /home/username/public_html/wp-content/uploads/2010/08. Is its parent directory writable by the server?

    Folder permissions have not changed, but I am now unable to make any changes to the 2010 folder and sub-folders permissions. When I try to create an alternate location for uploads, such as /home/username/public_html/wp-uploads/, the same problem occurs. I am able to modify the directory permissions before attempting to upload, but as soon as I attempt to upload an image, I receive the above error and am no longer able to modify folder permissions at all.

    I have tried downgrading back to 3.0, but the problem persists. I tried a manual upgrade to 3.0.1, deleting my wp-admin and wp-includes folders and uploading the fresh files, as the guide recommends.

    I’m not sure what else to do.

Viewing 2 replies - 1 through 2 (of 2 total)
  • lloaizav


    Did you tried changing permissions with Filizilla it works for me.



    No. I’ve been trying to change permissions using Flash-FXP and am being told “Operation not permitted.” I just checked, my 2010 folder is 766 already.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to upload images ("Unable to create directory" error)’ is closed to new replies.