Support » Fixing WordPress » Unable to upload images

  • mdknight

    (@mdknight)


    When I attempt to upload a header image I get this error
    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    Not matter how small I make it. I am using the Neve theme and Elementor
    yes I have tried switching the theme and disabling all plugins

    The page I need help with: [log in to see the link]

Viewing 15 replies - 31 through 45 (of 135 total)
  • Guys, here is the solution…go to Cpanel under security and disable ModSecurity.

    Hope it helps.

    in my case, i dont have SMUSH plugin. Let me turn it on, then disable plugins one by one and find the culprit. I’ll report back shortly.

    I’ve managed to resolve this issue by deactivating all the plugins, then going to the upload media screen then going back and deactivating all my plugins. Simply deactivating all the plugins and then reactivate them doesn’t seem to work you need to go to the upload media screen for it to work.

    I have the same issue too. Clearing the cache hasn’t worked. Directly uploading to media also doesn’t work. It would be good if this issue could be resolved.

    I have finally managed to get a work around for this. It’s a little long winded but it works.

    1. Go to your media library and select any picture. Preferably one that you managed to upload successfully. Click Edit and look at where the picture is located. keep this open or remember it.

    2. Connect to your server via a FTP client and navigate to this folder where your images are stored. Upload your large photographs to this folder.

    3. They won’t show up in your media library yet. You need to use a plugin called ‘Add From Server’. Download that and install/activate it (by Dion Hulse).

    4. Backup your WordPress installation (just in case).

    5. Finally, hover over Media and then select the new option = Add From Server

    6. Navigate to the folder where you uploaded your photo’s to. Make sure you select just the photos you want to import into your Media Library (although you could delete the duplicates if you make a mistake).

    7. After you click go, it’ll take some time, but don’t cancel it or refresh the page. Just wait, and you’ll get a notification on the same screen when it’s done. Along with a new list of imported files (including size variations if applicable).

    8. Now your photos will be in your media library with ‘scaled’ at the end. You can now use these in your posts and they will work just fine.

    NOTES
    The files are imported to wherever you select them from. So it’s important that you put them in the same folder as the rest of your active pictures BEFORE you import them. Other wise they’ll show up in the media library, but won’t actually work on your website (took a while to figure this out).

    I’d recommend importing 10-15 pictures at a time if they are large. Any more and you risk being signed out of your cPanel due to inactivity and it may break your installation (maybe, hence the backup).

    Hello Good People,

    Use this plugin until they solve the wordpress v5.3 problem

    https://wordpress.org/plugins/disable-big-image-threshold

    Thanks 🙂

    • This reply was modified 7 months, 2 weeks ago by ramymostafa.

    @johnyelland1234 @ramymostafa plugin doesn’t work for me either… need to go the FTP route and then import from server.

    Pretty serious bug IMO. Guessing it’ll be patched in the next version. Hoping it’s sooner rather than later as someone else in the thread said… images are pretty big part of many bloggers websites built on WordPress.

    Is there any way to upload the media files through FTP and then add them on the web site ? I have tried but the files do not appear on the media file list….

    Uploading via FTP is enough. Find out where your files currently are that do appear and memorise the location. Upload your new photos to that new folder.

    Then use the Add From Server Plugin to put them into your media library. Uploading them via FTP isn’t enough. And they must be uploaded to the correct place.

    Thanks ! This worked for me. The file does appear on the media folder and can be used wherever it may be needed.

    No problem, glad it worked. It’s stopped working for me of course. But as it was working before, I assume it’ll probably work tomorrow lol

    Ran wp-cli command wp cache flush and that solved my issue.

    @grezes71
    Probably best if you start a new thread for that specific issue so it doesn’t confuse this thread.

    Put a link on here and I think I have a solution for you. A work around at least.

    @jgodean No problem you’re very welcome. Glad it worked.

    Hi everybody. I saw this problem in several posts and found a workaround that worked for me, I share it with you:

    Problem: In the following situations the image upload form goes blank:
    – Gutenberg Editor > Featured Image > Upload Files
    – Gutenberg editor > image block > Media library > Upload files
    – Gutenberg editor > gallery block > Media library > Upload files

    Development tools report the following error:

    Uncaught TypeError: Cannot convert undefined or null to object
        at g.cleanup (load-scripts.php? c = 0 & load [chunk_0] = hoverIntent, common, admin-bar, jquery-ui-position, wp-pointer, heartbeat, jquery-ui-sortable, postbox, backbone, wp- util, wp-backbone, med & load [chunk_1] = ia-models, wp-plupload & see = 5.3: 29)
        at g.off (load-scripts.php? c = 0 & load [chunk_0] = hoverIntent, common, admin-bar, jquery-ui-position, wp-pointer, heartbeat, jquery-ui-sortable, postbox, backbone, wp- util, wp-backbone, med & load [chunk_1] = ia-models, wp-plupload & see = 5.3: 29)
        at r (load-scripts.php? c = 0 & load [chunk_0] = hoverIntent, common, admin-bar, jquery-ui-position, wp-pointer, heartbeat, jquery-ui-sortable, postbox, backbone, wp-util, wp-backbone, med & load [chunk_1] = ia-models, wp-plupload & see = 5.3: 29)
        at l (load-scripts.php? c = 0 & load [chunk_0] = hoverIntent, common, admin-bar, jquery-ui-position, wp-pointer, heartbeat, jquery-ui-sortable, postbox, backbone, wp-util, wp-backbone, med & load [chunk_1] = ia-models, wp-plupload & see = 5.3: 29)
        at h.Collection.n.off (load-scripts.php? c = 0 & load [chunk_0] = hoverIntent, common, admin-bar, jquery-ui-position, wp-pointer, heartbeat, jquery-ui-sortable, postbox, backbone, wp-util, wp-backbone, med & load [chunk_1] = ia-models, wp-plupload & see = 5.3: 29)
        at i. <computed> [as off] (media-views.min.js? see = 5.3: 1)
        at i.dispose (media-views.min.js? see = 5.3: 1)
        at i.dispose (media-views.min.js? see = 5.3: 1)
        at i.remove (media-views.min.js? see = 5.3: 1)
        at underscore.min.js? see = 1.8.3: 1

    Workaround: In my case, apparently the problem is related to the use of plugins that extend the functionality of the Media Library, deactivating these plugins can solve the problem until a definitive solution is found.
    Hope WordPress team fix this soon.

    • This reply was modified 7 months, 2 weeks ago by Daniel.

    @damen02 right, this seems like the most common problem here. As it is a js error in a plugin, it is not limited to just uploads but perhaps trying to upload an image is the most common way to trigger it.

    This should be fixed in the affected plugins. A temporary workaround until then may be to upload from the “Add New” screen on the Media Library list view. That screen doesn’t use Backbone and should allow uploading. To access it: go to Media Library, click on “List View” (the left of the two small buttons right under the “Media Library” title), click on Add New.

Viewing 15 replies - 31 through 45 (of 135 total)
  • The topic ‘Unable to upload images’ is closed to new replies.