Support » Fixing WordPress » Unable to upload images

  • When I attempt to upload a header image I get this error
    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    Not matter how small I make it. I am using the Neve theme and Elementor
    yes I have tried switching the theme and disabling all plugins

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 66 total)
  • Been using media library to upload. Then opening a new tab for the post and uploading it that way. It works most of the time but sometimes I have to do it 2x. The feature image doesn’t upload unless I filter by “images uploaded to post”. I hope this gets fixed asap.

    If you know what you are doing, you can use the Theme Editor to add this line to your functions.php (do it in your child theme – otherwise when you update your main theme it’ll get overwritten each time)

    add_filter( 'big_image_size_threshold', '__return_false' );

    That’ll turn off the image scaling introduced in WordPress 5.3.

    • This reply was modified 3 weeks, 4 days ago by mintWP.
    Parker

    (@parkerproject)

    @bilal9808 What you have suggested is not really a fix but a temporary workaround uploading through the media library. The issue here is not being able to upload an image using the image block in the editor

    digitalmalepinups

    (@digitalmalepinups)

    On my top ribbon I don’t have just a ‘Cache’ link that @dazzroberts referenced, only “Clear Cache” which doesn’t give a ‘purge all’ option. I clicked “Clear Cache”, tried to upload directly into the Media Library, still got the error message – the file uploads but gets downscaled.

    Even after using the ‘Clear Cache’ additional times, the same behavior persists (where the file uploads, and, the filename gets appended with ‘scaled’ and the resolution is downscaled) regardless of where I upload the file to (media library, products page, etc.)

    This will not work for me as I sell Digital prints and I (and customers) expect the file to be in its original size/resolution.

    I usually upload images at 3000px wide but I compress them locally with ImageOptim so the files are always under 1MB.

    @alikgriffin yes, this is exactly the purpose that threshold was added, to make large images more “web ready”. The “big image threshold” value can be changed to 3000 (or anything that makes sense in your case) from a small, private plugin. That behavior can also be disabled completely as mentioned by @askmintwp. See https://make.wordpress.org/core/2019/10/11/updates-to-image-processing-in-wordpress-5-3/.

    There is also a plugin to disable it: https://wordpress.org/plugins/disable-big-image-threshold/.

    @ken01102018, @eemskrant, @tfrederick014, part of the new functionality added in WP 5.3 is to retry image post-processing after upload. When there is a “server error” (usually meaning the server has run out of resources while creating image sub-sizes) it will try up to five times to finish the post-processing.

    It is possible that your server is under heavy load while you’re uploading an image (especially if you’re on shared hosting). Reducing the size of the image will reduce the server resources needed to post-process it. However this doesn’t guarantee the image will be post-processed successfully as that depends on the server.

    In such cases in WP 5.2 and earlier you would have seen the “HTTP error” message straight away and the upload would have failed.

    • This reply was modified 3 weeks, 3 days ago by Andrew Ozz.

    @andiwest, ha, so my guess was correct 🙂

    Glad to hear it is resolved now.

    @askmintwp, right this filter can be used to either disable image scaling or change the threshold. More info: https://make.wordpress.org/core/2019/10/11/updates-to-image-processing-in-wordpress-5-3/.

    However it’s not a good idea to add that to the theme’s functions.php.

    There is a plugin for it 🙂
    https://wordpress.org/plugins/disable-big-image-threshold/

    This will not work for me as I sell Digital prints

    @digitalmalepinups what plugin are you using to sell them? Sounds like it needs a small update to link to the full size files. Again, more info here: https://make.wordpress.org/core/2019/10/11/updates-to-image-processing-in-wordpress-5-3/, or alternatively install https://wordpress.org/plugins/disable-big-image-threshold/.

    digitalmalepinups

    (@digitalmalepinups)

    @azaozz I don’t think any of my plugins (using woocommerce for selling) – it worked as expected until updating wp to 5.3. I will look at that plugin you reference. Thanks.

    I installed the aforementioned plugin, disabled all caching plugins… nothing I do is working. I still get the same message and am unable to upload any photos. This is a serious problem since the images are integral to my posts. Any other ideas on how to fix this?

    @animemom sorry to hear that.

    Could you do the steps here: https://wordpress.org/support/topic/unable-to-upload-images-67/page/2/#post-12133521 and post all the errors you see. I’m sure we will be able to get to the bottom of it 🙂

    • This reply was modified 3 weeks, 2 days ago by Andrew Ozz.

    @azaozz I posted the console error I got when trying to upload an image. Please note that this image was less than 200kb (800×600) so the whole rescaling discussion is moot. My main issue is that the classic editor is broken due to a javascript error. Any clues?

    @rglcote i have the exact same Problem as you….
    I am using the Theme “FIRST” and it’s this Theme that is causing this malfunction.
    If test without the Theme via “Healthcheck” it’s working as normal…

    @rglcote, @sibtig this seems to be a different error, possibly caused by the Backbone.js update and a plugin/theme:

    backbone.min.js?ver=1.4.0:1 Uncaught TypeError: Cannot convert undefined or null to object

    Unfortunately the “error trace” you posted doesn’t provide enough info on where it comes from. Could you try adding:

    define( 'SCRIPT_DEBUG', true );

    to your wp-config.php. Then start a new thread with the errors you see in the console. This may provide a better “trace” and point to the script that causes it.

    (After the tests you should remove SCRIPT_DEBUG as it would slow down your site, or at least wp-admin.)

    • This reply was modified 3 weeks, 2 days ago by Andrew Ozz.
Viewing 15 replies - 16 through 30 (of 66 total)
  • You must be logged in to reply to this topic.