Support » Fixing WordPress » Unable to upload image in Media

  • This question is very common but I’ve failed to find a solution in all previous topics.
    Im craving for a solution!!!

    I get error message “An error occurred in the upload. Please try again later.” every time I try to upload a new image to “media”. It doesn’t mather which file type or what size I try.

    This started after I uploaded my site from local host and started using wp-admin in the browser.

    I use MacBook, Chrome, BeTheme IT-service
    Website: http://www.cellsolar.se

    This is what I’ve tried:

    1.Reinstalled WordPress
    Put this is your themes function.php
    first solution1:

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );

    function change_graphic_lib($array) {
    return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );
    }

    2. The issue was related to my server configuration not having the proper amount of memory allocated to Apache/PHP.

    If anyone has this same problem, please try verifying that you have enough (64MB+) server memory allocated to Apache/PHP in your server configuration settings.
    You can also add this to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’64MB’);

    3. Connect to your website using the FTP client and then go to /wp-content/ directory. There you will see /uploads/ folder. Right click on the uploads directory and give file permission 755.

    4.Deactivated and reactivated the theme
    5. Deactivated and activated all plugins
    6. Uncheck the box “Organize my uploads into month- and year-based folders” under SETTINGS > MEDIA >

Viewing 2 replies - 1 through 2 (of 2 total)
  • “An error occurred in the upload. Please try again later.”

    Someone please help. I cant afford web support.

    Have you contacted your host? I’ve run across this more than once in the past and the cause was that the host had incorrect permissions set on the uploads folder.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to upload image in Media’ is closed to new replies.