Support » Plugin: All In One WP Security & Firewall » Unable to upload ANY MP4 file

  • With the plugin enabled, I cannot upload ANY MP4 file, when logged in as admin. One I deactivated the plugin, I could upload MP4s with no issues.

    Please advise how to fix this issue. Thank you!

    • This topic was modified 3 years, 11 months ago by wolfgrrl.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, when you try to upload an MP4 file what error message to you see on your screen?

    Thank you

    Thread Starter wolfgrrl

    (@wolfgrrl)

    A simple “http error” and nothing more.

    Thread Starter wolfgrrl

    (@wolfgrrl)

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, can you disable all Firewall Rules. Then carry out a test? If you are able to load an MP4 file then you know that one of the Firewall Rule is causing an issue. If that is the case, you can start enabling one by one the options you want to enable and at the same time carrying out a test.

    Also what size is the file you are trying to upload?

    Let me know what happens.

    • This reply was modified 3 years, 11 months ago by mbrsolution.

    Hi, I have also had this problem today and I have had my host increase allsorts of limits to try and get rid of this HTTP error, turns out its the firewall rules in the htaccess file generated by this plugin. Swapping the htaccess file with a default one allows me to upload the MP4 (which was 40mb).

    I’ve just noticed that the “Basic Firewall Settings” includes a rule to limit upload file file size to 10mb so could be this, but there is no option to only disable this, I would be required to disable all of the Basic Firewall Rules as a whole which I dont really want to do.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @adejones and @wolfgrrl, please read the following documentation to increase the upload limit in your site if that is what is causing this issue.

    Let me know if you need more help.

    Thank you

    Thread Starter wolfgrrl

    (@wolfgrrl)

    This should be a setting within the firewall rules and not require editing the htaccess file directly. 10mb might have been sufficient a few years ago, but it’s impractical now.

    Can this be included in the next release please? Thank you! 😊

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @wolfgrrl, thank you for your comment. I have submitted a message to the developers to investigate further your request.

    Kind regards

    Plugin Contributor wpsolutions

    (@wpsolutions)

    Can this be included in the next release please?

    We’ll see what I can do.
    In the meantime the solution is easy – just deactivate the basic rules and paste your modified version in the custom rules section.

    Hi @mbrsolution – we know that it’s the basic firewall rules stopping the upload now so increasing limits on the server wont help, so have disabled the rules for now to allow the upload.

    Agree with @wolfgrrl that a future release should either omit the upload limit of 10mb which is far too low these days, or allow us to select/deselect each of the rules in the basic firewall rules set.

    As @wpsolutions suggested, I would like to include all the ‘other’ basic firewall rules in the custom rules section, but looking at htaccess I can’t seem to identify them, so could I have a little bit of help on this please?

    Thanks

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @adejones, all firewall rules begin with a tag and end with a tag. It is very simple to follow.

    For example: If you enabled prevent image hot licking then you will see the following start and end tags in your .htaccess file.

    #AIOWPS_PREVENT_IMAGE_HOTLINKS_START
    #AIOWPS_PREVENT_IMAGE_HOTLINKS_END

    Let me know if you need more help.

    Thank you

    Thanks for the explanation, seems easy enough, although looking through htaccess I cant see any tags that relate to basic firewall rules.

    Adrian

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @adejones, if you get stuck in any case you can find out which feature adds the extra code in the .htaccess file.

    First you disable the feature and you check the .htaccess file. Then you enable the feature again. You should be able to work out what was added when you check the .htaccess file again.

    Let me know if you need more help.

    Kind regards

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Unable to upload ANY MP4 file’ is closed to new replies.