Support » Fixing WordPress » Unable to upgrade Plugins after installing WP3.5

  • Resolved ukmobsco


    I am a novice user of 6 weeks.

    I backed up my site then upgraded to WP 3.5 last night.

    This morning there were 3 Plugins that required an update but when I tried to upgrade I received this error:

    PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature.

    Checking old support threads suggested that it might be I was at the limit of my hosting amount or file permission errors.

    It is not hosting limits and Hostgator have checked my file permissions.

    Any thoughts?

    Updating plugins was fine yesterday BEFORE upgrading to 3.5.


Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Try upgrading the plugins manually using FTP.

    Same for me. I’m using a windows server. windows 2008 r2.

    Was working just fine before I upgraded to 3.5

    Now I get an error:

    “Download failed. Destination directory for file streaming does not exist or is not writable.”

    I can upload a zip file using the web interface OK, and I can update by ftp ok. Just the auto update is broken.

    Any ideas?

    TY Esmi,

    FTP is not something I have learnt as of yet.

    I can access my files directly via the cPanel.

    What file and what folder should I install any Plugin upgrade I download direct from the Plugin Author site?

    (guessing I have to unpack any zip files and put the relevant upgrade into wp content / plugins / “relevant plug in” / what folder?)



    Forum Moderator

    I can access my files directly via the cPanel.

    Then you should be able to use cPanel’s File Manager. You’ll need to download a copy of each plugin to your computer, unpack it & extract the folder inside. Then copy the folder & its contents to wp-content/plugins.

    thank you Esmi.

    Hopefully the issue of automatically accessing plugins and upgrades will be resolved in due course as it seems to be an issue generally with the release of v3.5.

    I shall watch, wait and hope.




    Forum Moderator

    This definitely isn’t WP 3.5 specific. Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    I’m not sure that is correct, certainly in my situation.

    I have many wordpress installations on my server, and have only upgraded one to 3.5 and it’s the only one with problems.

    I have just updated the plugins on a different site, just fine. I even checked the permissions on the wp-content folder and it’s children. All fine. And more importantly, all the same on the both sites. One works, and one doesn’t.

    It’s odd that the upload a zip file works, but the updating and installing from the web doesn’t.

    My money is on the streaming component and maybe a compatibility issue with a version of PHP?



    Forum Moderator

    I upgraded 13 sites this morning across a range of hosts, servers & PHP versions without any problems.

    The upgrade went fine. Just updating plugins afterwards.

    If you have a “Download failed” issue when auto-upgrading, you can find the fix in the sticky at the top of the forum.

    To expand on this. It turned out to be a PHP bug, that was exposed by a 3.5 enhancement. A fix is being discussed for WP 3.5.1. You can follow the ticket.


    Don’t know how but this morning as part of my dailiy site health routine I tried to update the Plugins and it worked first time.

    The only thing I did last night was to clear all Caches (which I had done before) and completely close down all PC’s & Machines.

    Perhaps there was a “ghost” in one of the memories or something.

    Anyway alll fine now and I have learnt a valuable lesson.

    Don’t hit the upgrade button until:

    1. You’ve read the advice and articles relating to the upgrade on this Forum.

    As a Novice I would have waited a few days for things to settle down and for me to understand some issues (like with Bulletproof) before jumping in feet first.

    Thank you everyone for your input and taking the time to reply to me.


    Thanks, Esmi. Temporarily setting wp-content’s permissions to 766 did the trick.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Unable to upgrade Plugins after installing WP3.5’ is closed to new replies.