WordPress.org

Support

[Resolved] Unable to upgrade

  • I am unable to access my gallery, all I get is this:

    “The script detect that you upgrade from a older version. Your database tables for NextGEN Gallery is out-of-date, and must be upgraded before you can continue. If you would like to downgrade later, please make first a complete backup of your database and the images.

    The upgrade process may take a while, so please be patient.

    Start upgrade now…”

    When I press Start Upgrade now, nothing happens. What do I do?

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 19 total)
  • I have the same behavior after updating to 1.9.9 on WP 3.5.

    When I try the same I get the fatal error

    “Call to undefined function ngg_upgrade() in /var/www/vhosts/leimenblog.de/public_html/wp-content/plugins/nextgen-gallery/admin/upgrade.php on line 179”

    I guess that (deinstallin and) installing the latest version from scratch will delete all existing galleries, which is NOT a good idea.

    So what can I do?

    I have the same problem as mentioned above. The galleries are still displayed on the website but i’m not able to manage the galleries.

    Same here, and when I want to add any photo from the media library to the post, it says there are no media files.

    Hi inTagger – could you please explain a bit?

    I.e. what I (we) have to do with that stuff?
    I`m not a programmer, just “normal” low level admin …

    Does it mean take out read line and insert green lines in the code??

    Could you post somewhere the corrected version of the file – which would make it much easier and saver for people like me.

    Thanks a lot

    Fritz

    Same problem here!

    @fritzu, I’m not a php-developer, and just point where the code was changed which caused this problem. I think NGG developer should fix this ASAP. Waiting for update…

    I have the same Problem here
    Fatal error: Call to undefined function ngg_upgrade() …/wp-content/plugins/nextgen-gallery/admin/upgrade.php on line 179

    What can i do?

    I had this problem today. I not programer, but I made this:
    1. I downloaded previos version (1.9.8) from here http://wordpress.org/extend/plugins/nextgen-gallery/developers/
    2. In folder nexgen-galery/admin there are file upgrade.php
    3. Replaced new version file with older version .

    Now it works. (for me)

    I did that, and now have 1.9.8.

    Site is still messed up, but it’s probably the WordPress 3.5 problem (can not view my pictures in my Media Library and add them to posts and can not set the Featured image).

    I am using WP 3.4.2 ,seems evetything works . ( add pictures to galleries, insert them to posts ).
    You can try to upgrade nextgen via WP panel after file changes.

    Same problem here… After upgrading my WP to the latest version, I upgraded my NGG plugin and now I’m having:

    Fatal error: Call to undefined function ngg_upgrade() in …/wp-content/plugins/nextgen-gallery/admin/upgrade.php on line 179

    error.

    My galleries are still showing up in front-end but in admin section I can’t do anything with NGG Gallery panel…. It keeps saying:
    The script detect that you upgrade from a older version. Your database tables for NextGEN Gallery is out-of-date, and must be upgraded before you can continue. If you would like to downgrade later, please make first a complete backup of your database and the images.

    The upgrade process may take a while, so please be patient.

    Start upgrade now…

    @juozascc your solution worked for me! Thanks a ton!!!

    -Abhi

    @juozascc solution appears to work. Use an old version of upgrade.php in nexgen-galery/admin and the upgrade runs.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Unable to upgrade’ is closed to new replies.
Skip to toolbar