Support » Fixing WordPress » Unable to update WordPress theme

  • I have a WordPress theme thats installed and has been running fine for a while. I recently needed to update the theme itself, and I did so using the built-in theme editor. Upon reloading the site, the theme changes are not presented in the markup.

    Removing the index.php file from the theme or changing it’s name results in a blank page as expected, but removing all contents of the theme’s index.php does not have a similar effect. In fact, the WordPress installation continues as if I had not made index.php blank.

    I have no caching plugins installed, Varnish is not present, memcached is not in use at all, and neither is APC.

    I attempted upgrading all the plugins and WordPress itself. The raw-html plugin I have installed failed to update with a fatal error about an include on line 16, but that include was not present. The update worked fine when I renamed the plugin filename though (from raw_html.php to raw_html1.php).

    I’ve “updated” WordPress 7 times to 3.1.3, and it still believes it’s on 3.1.2. The files installed are definitely the 3.1.3 files. This may or may not be related.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Dumb question, but you’re sure you’re updating the theme that’s actually active on the site, right? You’re not trying to update a parent theme while a child theme is active or anything, are you?

    I don’t know if the weird upgrade issue is related or not; but I’ve seen a handful of other people report that they’ve had that same issue with the upgrade to 3.1.3.

    I’ve manually deleted all the other themes on the box, so yes, I’m updating the correct theme. If I weren’t, deleting the index.php file in the theme folder wouldn’t have any effects.

    I’ve done the changes both through the WordPress editor as well as through ssh+nano.

    Can you give me a list of the files that are in your theme’s directory?

    Here is a screenshot:

    Very strange.

    Any chance you can try updating WordPress manually to see if that corrects the version error and possibly the theme issue?

    It appears I was wrong about APC caching, so I’m currently in the process of attempting to get a new admin hook into the WordPress core for when a theme is updated.

    I also appears someone tried this a few months ago, and the issue was punted without much response.

    I’ve made this simple plugin, seems to work well enough, that creates a sudo-hook around both theme and plugin updating:

    One caveat is that I think themes are loaded before plugins, and so it looks like calling this hook from a theme’s functions.php file fails. Not sure what the best solution to this is.

    I’ll also post this to the trac ticket in case anyone wants to use it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to update WordPress theme’ is closed to new replies.