Support » Plugin: Jetpack by WordPress.com » Unable to update to version 2.8

  • Resolved darloup

    (@darloup)


    Hello,

    I get an error message when I try to update to version 2.8. I’ve been using Jetpack for a long time, and this is the first time I meet with an update problem:

    Activation du mode maintenance…

    Mise à jour de l’extension Jetpack par WordPress.com (1/1)
    Téléchargement de la mise à jour depuis https://downloads.wordpress.org/plugin/jetpack.2.8.zip…

    Warning: touch() [function.touch]: Unable to create file /tmp/jetpack.tmp because No such file or directory in /home/darlou5/public_html/darloup.com/blog/wp-admin/includes/file.php on line 155

    Warning: unlink(/tmp/jetpack.tmp) [function.unlink]: Operation not permitted in /home/darlou5/public_html/darloup.com/blog/wp-admin/includes/file.php on line 479
    Une erreur est survenue pendant la mise à jour de Jetpack par WordPress.com : Le téléchargement a échoué. Impossible d’ouvrir le gestionnaire de fopen() pour /tmp/jetpack.tmp
    Désactivation du mode maintenance…

    I’m using the French version, but the error messages are in English.

    If someone could help me please !

    With my anticipated thanks!

    Henry

    https://wordpress.org/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi Henry,

    If you have access to your server configuration settings, please update PHP_FCGI_CHILDREN from 1 to 2, restart your server, and then try to update the plugin again.

    If you’re not sure how to do so, please contact your hosting provider to see if they can help with this.

    Let me know if that helps.

    Hello Richard,

    Thanks for your prompt reply. I’ve now contacted my hosting provider and I’m awaiting their reply.

    By the way, I’ve noticed (on this forum and others) that there are MANY people experiencing the very same problem with the very same error messages.

    Do they all suffer from the same server misconfiguration?!

    Best regards,

    Henry

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi Henry,

    You’re right, there have been a few similar reports. I haven’t been able to see anything in common to them, however. If the suggested fix doesn’t work, can you please use Jetpack’s Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on “Help” tab in the upper right side of the page and click the link for “Jetpack Debugging Center.”
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button.

    Thanks!

    Hello Richard,

    Problem solved by the technical department of WebHostingHub.

    All that is needed is to add

    define('WP_TEMP_DIR','/home/darlou5/tmp/');

    in the wp-config.php file.

    I then managed to uodate to version 2.8 of Jetpack without any problem!

    Best Regards,

    Henry

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to update to version 2.8’ is closed to new replies.