Support » Fixing WordPress » Unable to update templates

  • Since updating to 2.0.1, whenever I attempt to save a template I get the following message:

    Service Temporarily Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Worked fine before the upgrade.

    Any ideas? It’s my own template so can’t believe it was affected by the upgrade process.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Can’t be certain, but sounds like a problem with your server. Perhaps speak to your host about it.

    Nope. It seems to have something to do with the quantity of content that you’re updating. Only happens in WordPress.

    Okay, I’ve worked tech support and know how bizarre this looks, but I can reproduce this reliably.

    I was trying to update a short template with a few lines of code, and got the above error. I narrowed it down to a problem when I tried to insert the following line:

    $feed_contents = curl_exec($ch);

    In that case I get the error message noted above.

    What’s even weirder is that if I change the “exec” to, say, “exce”, the update works fine.

    Changing other parts of the line — say curl to clur — doesn’t have any effect. It just appears that if “exec(” appears in the file the error above will appear.

    I’ve checked this on a completely different file — 404.php — and confirmed that the error appears when I try to add the string “exec(” to that file. Transposing characters (i.e. “exce(“) and the update goes through fine.

    I’m on WP 2.0.2. I’ve got other ways to edit the file without using the WP Admin module — but it might be a problem someone could look into.

    And what I don’t know could fill several boxcars – so if there’s a reason I shouldn’t be using the above code (copied from the Dreamhost wiki), I’m glad to be instructed.

    Okay, I’m still getting the error mentioned in the original post, but the problematic string isn’t quite the same as reported above. Steps to reproduce:

    1. Create an empty file in the theme directory (e.g. bugtest.php)
    2. Edit the file with the theme editor and insert the string
    exec();
    3. Click the update button

    Again, WordPress 2.0.2.

    If there’s no response, I’ll try to figure out the bug submission process.

    … contact your host.
    Confirm that they’re running mod_security.
    Gnash teeth.
    Beg host to relax the mod_security rules so that you can post things that their rules consider “hacking”.

    Thanks. That was the pointer I needed.

    Yes, indeed, on Dreamhost, for example, turning off the “extra web security” allows me to publish the file just fine.

    I’ve a request in to Dreamhost support to see if the specific code I need could be added to some sort of “whitelist”.

    And in the meantime, I’ve found that munging the line with some extra white space is enough to allow the publish to go through even with mod_security turned on. [Which makes me wonder how much “security” is actually being provided …]

    Dreamhost said they don’t plan to update the mod_security rules, but they may update
    http://wiki.dreamhost.com/index.php/KB_/_Web_Programming_/_CGI%2C_PHP_%26_Databases#Extra_Web_Security
    to give info about this issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to update templates’ is closed to new replies.