Support » Plugin: Wordfence Security - Firewall & Malware Scan » Unable to update rules

  • ResolvedModerator Steve Stern

    (@sterndata)


    Support Team Volunteer

    I have a number of sites that are reporting the same error, as follows.

    The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was March 10, 2019 6:33 am, so this site may be missing new rules added since then. You may wait for the next automatic attempt at March 24, 2019 6:33 am or try to Manually Update by clicking the “Manually Refresh Rules” button below the Rules list.

    Trying the manual update:

    No rules were updated. Please verify you have permissions to write to the /wp-content/wflogs directory.

    I do. See https://i.imgur.com/snqKQd4.png

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @sterndata,

    We have determined that this is caused by Wordfence timing-out when downloading new data signatures for malware detection.

    We are hoping to get a fix out as soon as possible. So for the time being, you can dismiss that warning message.

    Dave

    i have the same problem :/

    Me too…

    David

    (@dihetherington)

    Me too

    Plugin Support wfdave

    (@wfdave)

    We released an update that should have fixed this yesterday.

    Can you make sure you have the last update (7.2.4) and manually updating the rules?

    If that doesn’t work can you try deleting the rules.php file in wp-content/wflogs?

    Let Wordfence automatically regenerate the file (usually within 30 minutes) and see if the issue is resolved.

    Thanks!

    Dave

    b4rt1911

    (@b4rt1911)

    update fixed the problem for me
    thx

    socpsy

    (@socpsy)

    I have the same problem. I’m running latest updates of WP and WF. Deleting the rules.php file leads to a regeneration of a new rules.php, but the file is empty.

    samsara8

    (@samsara8)

    This update fixed my problems. Thank you a lot!

    I have 2 production sites where this error message shows. Interestingly, the dev/test sub-domains for each has no problem. I updated both prod sites to the latest version.

    That didn’t fix it so I deleted both their rules.php files per instructions above. A few minutes after doing so a zero byte rules.php file was created in the /wflogs folder but the message was still there. I then tried the Manually Refresh Rules button – no luck. Then I tried the “No rules currently set. Click here to pull down the latest from the Wordfence servers.” link right above that button but got the same error message.

    I’m going to try uninstalling/re-installing it on one of the sites.
    Any other ideas I should try out?
    Thanks!

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I’m still having problems on several sites, too.

    Still having this problem (as documented in the thread https://wordpress.org/support/topic/rules-update-failing).
    Using WP 5.1.1 and WF 7.2.4.

    Hoping that a resolution is coming soon.

    WF Support posted an update on the other thread:

    It has come to our attention that one of our servers where scan signatures and firewall rules come from is being blocked for some reason by a few hosting providers like Dreamhost. If you are not getting your rules updated and are hosted by Dreamhost (or any another hosting provider for that matter) please ask the provider to check and see if noc4.wordfence.com (69.46.36.20) is being blocked. If it is, ask them to unblock it for ports 80 and 443 and let us know if this was the case. If Dreamhost is blocking the IP then they are the only ones that can do anything to fix this.

    I filed a ticket with Dreamhost. Will update when they respond.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Thanks. My problem sites are on DreamHost as well.

    Thanks @therealmiked.

    Curious to hear what DreamHost finds. My sites — both the prod ones that are still getting the error message, and the dev ones that aren’t seeing it — are all on DH. Seems odd that only the prod ones are blocked??? I’m gonna wait until you give us an update before opening a ticket with DH. I had a Chat session with their tech support a week or so ago. It ended up that they didn’t find anything and their saying I had to Contact WF support.

    UPDATE!! It’s working now-:)

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Unable to update rules’ is closed to new replies.