Unable to update plugins & unable to install new plugins (8 posts)

  1. Leokoo
    Posted 2 years ago #

    Just updated wordpress to 3.4.2 to my website, http://www.fridgepirate.com

    Then, as I tried to update the plugins it said "updated successfully", but still showed as it hasn't updated after

    Also, when I tried installing a new plugin "wordpress seo by Joost/Yoast", it went well until the last part, it said

    "The plugin does not have a valid header."

    I checked the FTP and couldn't find the plugin installed in the plugin folder at all :(

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. Leokoo
    Posted 2 years ago #

    Thanks esmi, I deactivated all plugins and changed to the twenty eleven theme before posting here as those failed. =(

    how do we reset the plugins folder or reupload all files except wp-content folder? Will the database be affected?

    When I tried installing the seo plugin by yeost again, it said "folder already exist", then I checked via ftp and it didn't (!) :o

    that was http://www.fridgepirate.com

    When looked at outdoorgears.co, my other site that we're doing development on and had the same issues 2 weeks back, it said

    "invalid argument supplied foreach() in /home/xxx/domains/outdoorgears.co/public_html/wp-admin/includes/class-wp-filesystem-ftpsockets.php"

    Could it be a server setup issue?

    I don't have the same problem with my other site on a shared server, http://www.techgarage.my, though it's using the same plugins. Was supposed to migrate this site over to the dedicated one, but should I wait?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    how do we reset the plugins folder

    See the page at the link I posted above.

    or reupload all files except wp-content folder?

    You will need to use FTP or whatever file management application your host provides.

    Will the database be affected?


    Could it be a server setup issue?

    Doesn't look like it to me. That error message indicates a script/code issue.

  5. Leokoo
    Posted 2 years ago #

    ok, got it. Here's the update. I've 3 domains which i'm using to develop some ecommerce store
    1) techgarage.my
    2) outdoorgears.co
    3) fridgepirate.com

    Let's start with techgarage.my, test site was at /temp2 - we installed WooCommerce and Woothemes and started customizing the site. Was updating the plugins when the message "header was not found" came. Then tried again and it said "folder already exist" when it didn't.

    So we moved and reinstalled the original site from Joel, the developer's server on outdoorgears.co. And another copy at /temp2. Was busy updating outdoorgears.co when the same problem occurred. I suddenly cannot update the files from wordpress anymore.

    I contacted the developer and also WooThemes and got really fed up as both had no answers

    Yesterday, I thought of maintaining some sites and dropped by fridgepirate.com. it hardly had any plugins, no woothemes nor woocommerce and only Studiopress' Genesis plugins. After updating the core to 3.4.2, I proceeded with updating the plugins to which, it gave me "header not found" And subsequent retries gave me "folder already exist", which is not true. Checked FTP and it's not there :(

    Web Host created xx@fridgepirate.com and asked me to use it to update, which worked for now. But just like for outdoorgears.co, it might just stop working

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Are all of these sires on the same physical server?

  7. Leokoo
    Posted 2 years ago #

    hi Esmi! They're not. techgarage.my is hosted on a shared server, while the rest is on a dedicated one.

  8. Leokoo
    Posted 2 years ago #

    Could it be a server setup issue, or a wordpress issue?

Topic Closed

This topic has been closed to new replies.

About this Topic