Support » Fixing WordPress » Unable to update plugins after upgrade to v6.3

  • Hello,

    After I upgraded my site to wordpress 6.3, I am unable to update any plugin. I get the following error in French : Une erreur est survenue lors de la mise à jour de [plugin name] : Impossible de créer le répertoire upgrade-temp-backup.

    Which should translate to something like : An error occured while updating [plugin name] : cannot create the folder upgrade-temp-backup.

    I tried to manually create the folder upgrade-temp-backup in wp-content after reading this article but it didn’t fix the issue.

    Anyone having a similar bug ? Any advice on how to fix it ?

    Thank you.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Just to make sure, is that folder you created in the correct location and does it have the correct permissions? The error says indicates that this is either a not enough space issue or a folder permission issue

    Thread Starter eighilaza


    Hi, thanks for your reply. I changed the permissions to 777 and that fixed the issue. Before trying this, I had set the permissions to 775. What would be the best configuration to ensure least privilege ?

    I am not the correct person to answer that question. I would say trail and error… but maybe others on the forum can respond on that.

    I am having the exact same issue. 777 is to much permissions and could make the sight vulnerable. Someone from WordPress should chime in. I think the Upgrade to WP 6.3 caused this issue. Please chime in WordPress Team!!!

    I’m having the same issue on a site of mine (I am going to dig into this further).

    For now I downloaded the .zip file of my plugin, manually uploaded to override the plugin with the newer version and it worked just fine. Updating from within the dashboard gave that error.

    • This reply was modified 1 month, 1 week ago by Andrew Lima. Reason: fix typo
    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    There is a documentation article about that:

    Jos Klever


    The normal permissions should be 755, but if 775 isn’t even enough and you need 777 (writable for everyone), the web user isn’t part of the right group. So it’s not really a permissions issue, but an ownership issue and probably on the level of wp-content. It would be best to contact your web host to check the ownership of your files and directories and correct them, so the web users has permissions even with 755 for directories and 644 for files.



    I also had issues with this update! I had to create the folder manually, and have set the permissions to 775.
    At start I had to use 777, but then I discovered, as I use a bitnami stack, that the folder been created with bitnami as owner and group, so I changed the group to daemon, and then I managed to set the folder to 775.

    I guess this issue stating and ending with permissions. My wp-content was set 755. That’s why DAEMON couldn’t write or delete the upgrade-temp-backup. I have changed wp-content permissions to 775, and I expect to not have any longer any issues.


    • This reply was modified 1 month ago by neoswf.

    You should be able to simply delete the upgrade-temp-backup folder and it should be recreated.

    In Site Health what does the Plugin and theme temporary backup directory is writable display?

    It does need to be present for this test to have meaning.

    Andrew Lima


    Thanks @neoswf, I had to update my file permissions to 774 and I created all the folders needed and recursively added these permissions. (Copied permissions from other folders in the wp-content directory)

    This sites running on Digital Ocean with Server Pilot. Hope this helps anyone else that comes across this.

    Thanks @neoswf this was the correct solution.

    1 – mkdir upgrade-temp-backup in /wp-content
    2 – sudo chown daemon:daemon upgrade-temp-backup/
    3 – upgrade the plugins

    This started after update to 6.3

    @eighilaza can you or @neoswf create a Trac ticket so this issue can be further investigated?




    All the permissions editing suggested here did not help. I now have this issue:

    Warning: unlink(/opt/bitnami/wordpress/wp-content/google-analytics-for-wordpress-MIt39c.tmp): No such file or directory in /opt/bitnami/wordpress/wp-admin/includes/file.php on line 1182

    I get a similar issue updating any plugin for any of my sites

    I originally started with the cannot create the folder upgrade-temp-backup issue. This all started when updating to 6.3 on Lightsail (bitnami).

    Andrew Lima


    [Update] I think these providers need to tweak their services to support WordPress 6.3 functionality.

    For now manually downloading and updating does work as it doesn’t create a temp file from my tests.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.