Unable to update plugin or upload images (3 posts)

  1. Sissadora
    Posted 3 years ago #

    Hey all,

    I upgraded my WordPress blog and almost all the plugins related to it, but all of a sudden I started getting into some problems...

    I tried to add images to a post, and got an error saying

    “whatever.jpg” has failed to upload due to an error
    The uploaded file could not be moved to ......../public_html/blog/wp-content/uploads/2012/06.

    The directory exists and I have all the necessary write permissions - I didn't change them between yesterday and today!

    Then, I got another error.....

    Warning: touch() [function.touch]: Unable to create file ........./public_html/blog/wp-content/uploads/wordpress-seo.tmp because Permission denied in ......../public_html/blog/wp-admin/includes/file.php on line 177

    from trying to update the WordPress SEO plugin. I didn't change the permissions on the FTP whatsoever so this was a little odd. I went to the file mentioned, and it had write access for both owner and group (I'm not sure how my FTP server is set up, so I went for having both write accesses). I even quickly tried adding public write access and trying to update but to no avail.

    I also tried disabling all plugins and changing into a default theme but it didn´t help. Does anyone have an issue like mine?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try asking your host to check if there's they've created a file/folder ownership issue on the server. Remember to send them copies of these error messages.

  3. Sissadora
    Posted 3 years ago #

    Thanks Esmi. :) I'll indeed pop by my host's forums and support to see what they changed. Luckily mine seem to be small problems compared to those other people have...

Topic Closed

This topic has been closed to new replies.

About this Topic