Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Unable to update cropped thumbnail

  • I seem to be consistently unable to view a custom cropped thumbnail using FooGallery.

    After uploading a few images to a gallery, I will go into the Edit Image settings and create a new custom cropped thumbnail, save it, and click on Update.

    I can see my new cropped image in those editing screens, and when I go back to the gallery itself (in edit mode) I can see it there. It will not display in Firefox or Chrome despite countless refreshes. I have also tried this on a different website with a different hosting company (thinking the host has some caching going on). I have tried cropping the image using the Twenty Seventeen theme, and using the Genesis / Dynamik theme combo I always use. I’ve used the Regenerate Thumbnails plugin and I have cleared the Foo thumbnail cache on the Gallery page.

    Each time the issue is the same – can see my custom cropped image in the backend but not in any browser.

    Help! Any tips are welcome!

    Thanks…

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author bradvin

    (@bradvin)

    hi @hollykny,

    When you are editing an attachment thumbnail, you are editing the 150×150 image that is created when you first upload the image. I am assuming you are still using the standard thumb sizes in Settings -> Media.

    To force the gallery to use these edited thumbs, you need to:

    1) Make sure the gallery thumb size is the same as the WordPress thumb size in Settings -> MEdia
    2) Goto FooGallery -> Settings, under Images tab, make sure “Use Original Thumbnails” setting is checked.

    Let me know if that helps

    Hi @bradvin,

    Thanks for your input. I tried as you suggested, but it didn’t work.

    My Settings > Media was set to 225 x 225 proportional images. I changed the Foo thumbnail settings to “use original thumbnails” as you suggested. And then once inside an image in edit mode, I tried changing the Image Crop Selection to 225 x 225 but there are a few issues:

    1. It seems I have to set an Aspect Ratio first. I did that (1:1).
    2. I cannot always get the Selection fields to be active. Sometimes you have to go to Thumbnail Settings: Apply changes to Thumbnail and select that radio button first, then click on the image itself, and then sometimes Selection fields are active. Other times I see “NaN” in each selection field.
    3. Holding down shift and/or Control doesn’t always constrain it to a square, but sometimes it does.
    4. The crop tool isn’t always active to confirm the new crop especially when “NaN” appears in the Selection fields.

    Is there a proper sequence of events to perform these custom crops that maybe I’m just not touching upon?

    Plugin Author bradvin

    (@bradvin)

    From a image cropping point of view – that is all core WordPress functionality and not FooGallery, so I cannot comment on that. I also do not have much experience with cropping thumbs in the admin, especially when using a custom thumbnail size, so I am sorry I cannot help with that.

    But for your foogallery, is your thumb size set to 225×225 and crop?

    Oh okay – I didn’t realize that I was actually looking at WordPress functionality re: these crops. Since I accessed that page via the FooGallery itself, I assumed it was Foo’s screen.

    Right, my FooGallery is set to 225 x 225 and that matches the WP Media Thumbnails settings. When I can get the crop to work, I can see the new custom crop in the backend and in the FooGallery edit mode, but when I refresh the browser (and have tried several browsers, several OS’s and several different computers, even one out of state), it doesn’t seem to pull in the new cropped image.

    So it seems like there are 2 issues – one is the flaky behavior of creating the crops and two is that when it does work, Foo or something isn’t letting me see it on the actual page.

    Plugin Author bradvin

    (@bradvin)

    Hi

    I have been digging into your issue more and I think I know why the wrong thumbs are showing. It has to do with the retina settings for the gallery. If you untick all retina settings on the gallery edit page, does the correct thumbs then show?

    Hi Bradvin,

    Thanks for thinking about this some more! I just checked, and none of the retina settings have ever been selected …

    Holly

    Plugin Author bradvin

    (@bradvin)

    can you share a URL to your gallery?

    Plugin Author bradvin

    (@bradvin)

    Please can you try this version:

    https://github.com/fooplugins/foogallery/archive/develop.zip

    I have included a new setting on the gallery which allows you to force the gallery to use the original WP-generated thumb.

    Steps to follow:

    1) Deactivate and delete current version of FooGallery
    2) Download the zip from above link
    3) Upload and activate it in WP
    4) Goto FooGallery -> Settings and click the “Clear HTML Cache” button
    5) Edit the gallery in question. Scroll down until you see the “Thumbnails” metabox and check “Force Original Thumbs”. Then SAVE.
    6) Test if the original thumbs are being used

    Hi Bradvin – I’ll try that version later today and let you know how it goes. Thanks! If it doesn’t work, I’ll post a link to the test gallery for you.

    Hi Bradvin,

    Thanks again for continuing to thing about this issue. I installed your download above on a test site from scratch and am still experiencing the same odd issues. Here are details of what I did.

    After installing the plugin from the link above, I created a brand new gallery on a different test site.

    Inside the Foo Gallery edit page, I click on the “i” icon on top of the image to access the image editing section so I coul create a new thumbnail crop.
    That took me to a Media Library tab and on the right, I clicked on Edit Image.

    On the next screen labeled Edit Media, under Image Crop on the right, I set aspect ratio (1 : 1) and tried to make the selection be 225 x 225 but the selection fields were grayed out.

    Under Thumbnail settings – Apply changes to thumbnail = yes.

    I clicked the gray crop icon.
    Tried to drag inside photo to select new thumbnail region.
    Clicked gray crop icon again. Nothing happens.
    Image is not constrained to a square, either.
    Then “NaN” appears in the Selection fields.

    (This is not unique to your new plugin version – happens to me consistently)

    I clicked Cancel.
    Then clicked Edit image below image to start over.

    I tried to redo the thumbnail image. This time clicking crop icon second time to confirm worked.
    Clicked Update to save.

    Go back to the actual gallery page and refresh. The new cropped thumbnail isn’t appearing on the actual page.
    Go back to Foo Settings and click Clear Gallery HTML cache.
    Go back to Gallery in edit mode.

    Click the “i” icon on image whose thumbnail I want to change.
    Click Edit Image on the right.
    Re-select new crop region.
    get “Selection: NaN x Nan” error in box.
    Click Cancel.

    Click Edit Image under image.
    Try again.
    This time cropping works, click Update to save.

    Refresh gallery page. New cropped thumbnail is still not appearing on the actual page.
    Go back to Gallery. New cropped thumb is not appearing on the main Edit Gallery page either.

    Finally, I went to the Media Library directly to edit the image instead of clicking on the image inside Foo Gallery’s edit gallery page.
    I created a new cropped thumbnail, saved it. Refreshed the gallery page. It still isn’t appearing.
    Went back to open the gallery in edit mode – new crop IS appearing there. But the browser won’t display it on the actual page.

    Here’s a link to the test page/gallery. If you want login credentials you can contact me directly for them.

    http://hollyknottdesign.com/leigh/foo-gallery-test/

    Plugin Author bradvin

    (@bradvin)

    Hi and thanks for the detailed explanation.
    But, again, the image editing tool you are using is not part of FooGallery. It is part of WordPress core. If you navigate to it via the FooGallery edit page or directly from the media library, it is the same, so I cannot comment on the issues you are getting there regarding the NaN problems. Even with FooGallery deactivated you will still have that problem.

    But when you do manage to save the cropped thumb and it does update in the gallery edit page, did you do step 5 in my above reply?

    5) Edit the gallery in question. Scroll down until you see the “Thumbnails” metabox and check “Force Original Thumbs”. Then SAVE.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Unable to update cropped thumbnail’ is closed to new replies.