WordPress.org

Forums

[resolved] Unable to update core (5 posts)

  1. Magistar
    Member
    Posted 1 year ago #

    My wordpress is refusing to update (I changed language and it wants a core update).

    I keep running into file permission issues. I already set everything to 777 and still I am getting errors:

    Update WordPress
    Downloading update from https://downloads.wordpress.org/release/nl_NL/wordpress-3.9.1.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Preparing to install the latest version…

    Enabling Maintenance mode…

    Copying the required files…

    Warning: copy(/home/thewebsite/domains/website.nl/public_html/readme.html) [function.copy]: failed to open stream: Permission denied in /home/thewebsite/domains/website.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    Warning: copy(/home/thewebsite/domains/website.nl/public_html/readme.html) [function.copy]: failed to open stream: Permission denied in /home/thewebsite/domains/website.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    Warning: copy(/home/thewebsite/domains/website.nl/public_html/readme.html) [function.copy]: failed to open stream: Permission denied in /home/thewebsite/domains/website.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217

    Warning: copy(/home/thewebsite/domains/website.nl/public_html/readme.html) [function.copy]: failed to open stream: Permission denied in /home/thewebsite/domains/website.nl/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 217
    Disabling Maintenance mode…

    Could not copy file.: readme.html

    Installation Failed

    WordPress was imported by installatron in case that matters.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Looks like you have some permission errors on your site. You could upgrade manually.

  3. Magistar
    Member
    Posted 1 year ago #

    Uploading from ftp worked. Is there any way to prevent these issues?

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    You could have a word with your hosts about it.

  5. Magistar
    Member
    Posted 1 year ago #

    Thanks, I did. Apparently switching to Php 5.4 should solve this.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.