Support » Plugin: MetaSlider » Unable to translate some strings

  • Hi,

    i’m unable to translate some strings, maybe there is no __()[function] ?

    List :
    – ml-slider.php # L1200 : “Select Slideshow”
    – ml-slider.php # L1207 ? : “New Slideshow”
    – ml-slider.php # L1213 : “Create a New Slideshow” + create a new slideshow with no __()[function]
    – ?.php # L? : “New Slideshow”
    – ?.php # L? : “Preview”
    – ?.php # L? : “Use the image caption”
    – ?.php # L? : “Open in a new window”

    Not sure if we can translate the title and text bloc : “How to Use”

    Thx

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @devportobello,

    Behind the scenes we added some of the new JS __() functions but perhaps they aren’t compiling correctly.

    I apologize but I’m not familiar with how the translation process works. Do you use some software or just edit through the wp.org website?

    When you say you’re unable to translate them, do you see an error or something? If I can reproduce the error myself then I can tweak the system enough to fix it. Maybe you have a screenshot?

    Any help is appreciated, thanks.

    Hi @kbat82,

    I use Poedit to edit translation file (wp-content\plugins\ml-slider\languages) (In other side i also starting contribute to translate on wp.org metaslider plugin)

    No error to reproduce

    Metaslider Version 3.8.1

    Plugin Contributor kbatdorf

    (@kbat82)

    Thanks @devportobello, I will take a look this week.

    Question though. If you don’t see any errors, what indicates that you cannot translate those strings?

    Also, just so I can try to reproduce the issue, what language are you translating to?

    Thanks for the feedback!

    I tried to add in .po file some string but not working (msgid/msgstr)

    I translate to french

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @devportobello,

    Thanks again for the feedback, and sorry for the delay, but I believe I fixed this in 3.10.1. If you have time to check let me know if you have any feedback, thanks!

    Hi @kbat82,

    Seems not working, i downloaded again .po file but there is no translation :/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to translate some strings’ is closed to new replies.