Support » How-To and Troubleshooting » [Resolved] Unable to trackback for wordpress 2.0

[Resolved] Unable to trackback for wordpress 2.0

  • Follow this solution if
    1. you converted your db from 1.5.2 to 2.0
    2. unable to trackback, after click posting the trackback url remain at the trackback field

    thats because your to_ping field might contain some char ( including space, tab which represent by \n\r ), run this sql command under your phpmyadmin ” Update ‘wp-posts’ set to_ping=” “
    after this should be able to trackback already, i believe the dev change hows the trackback work, thats why there are no problem during 1.5.2 but cause some problem in 2.0, i will suggest dev team to add this sql in the upgrade script ?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The cause of this issue and the related patch can also be found at:Patch for WordPress 2.0 trackback issue

    Followed the Solved!! method and still no go. I tried using the patch. I was not able to use knight’s method as not sure how to run in my phphadmin. The patch files I uploaded to the folders. Still no trackback. Will there be a fix soon from wordpress?

    Neither the SQL nor the patch worked for me. How was this issue “solved”?

    first of all are we on the same issue ?

    unable to trackback, after click posting the trackback url remain at the trackback field

    do you see this happen ? if yes then we might on the same issue, for my case after i clean up the to_ping field, i can start trackback without any problem , so it does solve in my view

    Yes, same issue. I dropped and re-created the to_ping field, it had no effect. 🙁

    Mmm, I thought it was just me failing to send trackbacks…

    Nope. Looks like we should have waited to upgrade to 2.0

    Ah, the life of the early adopter.

    what’s the latest state in this issue? I googled around, followed both the “clean-up-to_sql” hint and the patch posted here, and trackback still seems broken. anything else to be done?

    TIA and bye,

    well… okay… forget about it, I’m stupid. just for the minutes: uploading the patched files indeed _does_ help once you manage to set permissions right. stupid mistake. 🙁

    Can someone clear up for me how to apply the patch?

    for execute-pings.php.diff and wp-includes for functions-post.php.diff) and applied the patch by “patch origfile patchfile?.

    This does not help me at all. Where do I place this command?


    Also the php query returned syntax errors
    ” Update ‘wp-posts’ set to_ping=” ”

    I uploaded the patched files (for those of us who don’t know how the “patch” command works) set the permissions, and I still can’t send trackbacks.

    Come to think of it, ever in version of WordPress I’ve used — 1.2, 1.5 and now 2.0 — trackbacks have been broken in the initial release. Every time.

    Can someone tell me what to do? I’ve uploaded the patched files to the appropriate directories. Now what? I’ve set the permissions so they can be read, written to and executed. What else do I need to do?

    any permanent solution?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Unable to trackback for wordpress 2.0’ is closed to new replies.