Support » Plugin: WooCommerce Stripe Payment Gateway » Unable to take payments – Stripe says I have no live SSL

  • Resolved whitehurstw

    (@whitehurstw)


    Hi
    Stripe V 4.1.15 // WordPress V 5.1.1 // Theme DIVI – V 3.21.1

    I have stripe payments installed. I have an active SSL (Lets Encrypt)

    When I try to make a card payments I get a front end error of “Unable to process this payment, please try again or use alternative method.”

    In the back end logs I get an error saying that it doesn’t recognise my SSL.

    2019-03-30T13:33:58+00:00 DEBUG
    ====Stripe Version: 4.1.15====
    ====Start Log====
    Stripe Payment Request live mode requires SSL.
    ====End Log====

    Any help of suggestions would be great, thank you.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Shane Eckert

    (@shaneeckert)

    Automattic Happiness Engineer

    Hi,

    It looks like you do have SSL enabled.

    If you view the log now, after saving the settings again and visiting the front end of your site, is the message repeated? It’s possible that’s an older message.

    If it is still present, please let me know.

    Thank you,

    Hi

    Thanks for getting back to me.

    The error message appears every time I try to make a payment and it also has the time above the log for each failed payment.

    Anything else you need please let me know.

    Thanks,

    Plugin Support yukikatayama

    (@yukikatayama)

    Automattic Happiness Engineer

    Let’s make sure your site is fully set up with SSL.

    Please append /wp-admin/options.php (so: https://www.basilar.co.uk/wp-admin/options.php) to your site URL and search for woocommerce_force_ssl_checkout. If you are on a Mac, you can open up a browser search box by typing Command+F and add that phrase. Please make sure the text field say yes. Then save the changes.

    I would also recommend making sure your URL does indeed show https, not http, when you go to Settings > General and check the text fields under WordPress Address and Site Address.

    Thanks!

    Hi

    Thanks for getting back to me.

    I’ve have changed the settings to force ssl as described and I am still have the same problems.

    I have however noticed that there is no updates in the logs with any error message apart from the message at the checkout “Unable to process this payment, please try again or use alternative method.”

    I have tried this with several cards of both myself and customer so I can rule out insufficient funds in the accounts.

    Thanks

    Plugin Support yukikatayama

    (@yukikatayama)

    Automattic Happiness Engineer

    Hi @whitehurstw,

    If I understand correctly, either the options.php page or your General settings didn’t have https originally, then? And now that they’ve been updated, you’re still getting the error message on the front end, but now not getting any specific error message in the debug log?

    Let’s check if there’s any theme or plugin conflicts with Stripe.

    First, backing up your live site before any testing and updates is highly recommended. If you would prefer not to do testing on your live site, first make a back up of your site, then create a staging site using this plugin [WP Staging](https://wordpress.org/plugins/wp-staging/). This creates a copy of your live site where you can make tests without affecting your live site.

    Temporarily switch your theme to one of our default – Storefront or Twenty Nineteen, then deactivate all plugins except for two – WooCommerce and Stripe. If it shows correctly, then it’s a theme or plugin conflict. Reactivating each plugin one at a time, then see if the issue pops up again will tell us which plugin is conflicting.

    Plugin Support Shane Eckert

    (@shaneeckert)

    Automattic Happiness Engineer

    Hi,

    We have not heard from you in awhile. I am going to mark this thread as resolved. If you still need assistance please open a new thread.

    Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.