Support » Plugins » unable to submit plugin using subversion

  • Resolved talimoon


    Hi All,

    I downloaded Visual SVN Server for windows for the purpose of submitting a plugin to wordpress. I installed it successfully and ran it.

    I tried to follow the below instructions to upload my plugin but it doesnt work. Of course i replaced “my-local-dir” and “my-plugin” with the relavant names.

    # Create a local directory on your machine to house
    # a copy of the repository.
    $ mkdir my-local-dir
    # Check out the repository
    $ svn co my-local-dir
    > A	my-local-dir/trunk
    > A	my-local-dir/branches
    > A	my-local-dir/tags
    > Checked out revision 11325.
    # As you can see, subversion has added ( "A" for "add" )
    # all of the directories from the central repository to
    # your local copy.
    # Copy the plugin files to the local copy.
    # Put everything in the trunk/ directory for now.
    $ cd my-local-dir/
    my-local-dir/$ cp ~/my-plugin.php trunk/my-plugin.php
    my-local-dir/$ cp ~/readme.txt trunk/readme.txt
    # Let subversion know you want to add those new files
    # back into the central repository.
    my-local-dir/$ svn add trunk/*
    > A	trunk/my-plugin.php
    > A	trunk/readme.txt
    # Now check in the changes back to the central repository.
    # Give a message to the check in.
    my-local-dir/$ svn ci -m 'Adding first version of my plugin'
    > Adding	trunk/my-plugin.php
    > Adding	trunk/readme.txt
    > Transmitting file data .
    > Committed revision 11326.
    # All done!

    Firstly i where it says copy the files to your local copy….
    Which files is it talking about? This is the first time im submitting the plugin, the only files i have are on my machine.

    Assuming it did mean the files that are on my machine i tried the copy command with the correct path and everything but it tells me cp is not a command…. then i tried copy it tells me it cannot find that path on the system…

    Finnally i just copied the files using copy paste in windows.
    K, now the files are there.

    I then used and add command to add the files it seemd to work. but then when i tried to checkin the files using the above mentioned command line it again gives me a fail error:
    “first’ is not under version control”

    Please can someone give me clear and simple instructions on how to do this?

    You don’t understand how frustrating it is to try and get some clear and simple instructions on how to do some of these things.


Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi all,

    I also tried to type just svn commit but then i get a big error:

    svn: Commit failed (details follow):
    svn: Could not use external editor to fetch log message; consider setting the $SVN_EDITOR environment variable or using the –message (-m) or –file (-F) options
    svn: None of the environment variables SVN_EDITOR, VISUAL or EDITOR are set, and no ‘editor-cmd’ run-time configuration option was found

    Please, I’m desparate! Can someone help me?


    i finally managed to figure it out.

    What did you do? I’m trying and I’m unable to submit. It returns

    > svn: URL ‘’ doesn’t exist

    – Terri

    Hi Terri,

    its difficult to comment on what you’re doing wrong. try and post the code that you are using step by step and i can try and tell you whats not right.

    i also used the SVN Book it gave me some pointers. Because i found that sometimes the abreviated version of a command does not work for some reason so you have to use the full one.

    I’m also quite new at this, and it took some playing around before i got it right.



    I met the same problem. Did you get it solved?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘unable to submit plugin using subversion’ is closed to new replies.