Support » Plugin: CF7 Google Sheets Connector » Unable to submit data to Google sheet

  • Resolved yasim12299

    (@yasim12299)


    Hi Support,

    I am currently using the free version. It was working fine earlier but somehow it stopped working at all. I have checked the configurations and all but it is not working at all now. I have updated the CF7 connector plugin and the CF7 but didn’t work out. Below are the screenshots of my settings.
    https://nimb.ws/SjU7EB
    https://nimb.ws/YZQIMC
    I have the debug log file enabled in congig.php
    The logs are empty. I am using it on my 3-4 sites and not working anywhere.

    Your help is highly appreciated.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author westerndeal

    (@westerndeal)

    Hello @yasim12299
    Thanks for your message and sorry for the trouble.

    I have gone through with your screenshots, can you correct the following
    1. Don’t use spaces in naming fields
    ex: referred-by and follow-up-notes write like this in cf7 name field and in sheet too.
    2. If still submitted data is not seen in sheet, then rename the file name without using underscore (_) you can use spaces in the sheet name
    3. To double-check, authentic is successful, click here
    https://myaccount.google.com/permissions and check-in 3rd Party Apps GSheet icon with name is showing, for successful authentication, you can remove manually from above link and reauthenticate again.

    Let me know if it helps so that I can guide you further.

    Thanks
    Abdullah

    Hi Abdullah,

    Thank you for the prompt response. I have tried the above-mentioned things but still, it is not working.

    for point 1, referred by and follow-up notes are my own columns and the data are not coming from the CF7. Here is the screenshot. https://nimb.ws/LUahg4

    looking forward to hearing from you.

    Thanks!

    Plugin Author westerndeal

    (@westerndeal)

    Hello @yasim12299

    Sorry for the delay in responding please do the following.

    1. In Column names avoid using space and instead use a hyphen
    eg: referred-by and follow-up-notes
    2. Make sure you are using correct sheet name, sheet id, tab name and tab id.
    3. After filling the form check the debug log link in Google Sheet menu under the contact form.
    4. If still having issues, I suggest you to create a new sheet or new tab once and reauthenticate again and check it out.

    For more refer all the common issues here

    Thanks
    Abdullah

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.