Support » Plugin: User Role Editor » Unable to show Admin role in URE

  • Resolved hangojango

    (@hangojango)


    Hello and thank you for an awesome plugin.

    I am setting up a multisite as the Super-Admin. With the membership plugin I’m using, members can create subsites for which they are the Admins.

    I would like to be able to add myself to those subsites as an Admin as well. However, when I go to Network > Sites > (specific site) > Users (to either Add Existing User, Add New User or Change role), I am not given the option of Administrator from the drop-down menu. Incidentally, Editor is missing too but all other roles are there.

    I followed the initial advice here: https://www.role-editor.com/forums/topic/in-multisite-allow-admins-to-create-admin-role/

    In other words, I went into Network > Settings > User Role Editor and in the General tab, I checked “Show Administrator role at User Role Editor” but this hasn’t changed anything.

    Is there any reason I cannot see Administrator (or for that matter, Editor) in the URE list?

    At the end of the page I previously referred to, there was a reference to this filter: ure_supress_administrators_protection
    I’m afraid I don’t know much about filters and what to do with this but I gather that it will let Administrator be seen as a role in URE. That’s ok with me because I will be the only one being allowed to view URE in the dashboard.

    Any help appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Vladimir Garagulia

    (@shinephp)

    URE does not hide ‘administrator’ role from the list of roles with “Show Administrator role at User Role Editor” option turned ON. You as superadmin should see ‘administrator’ role in the roles list.
    I suppose that some other plugin may be involved here.

    Try to deactivate all plugins and re-test. It case it will help, activate plugins back one be one in order to isolate a reason.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.