Support » Plugin: WP Cloudflare Super Page Cache » Unable to setup using subdomain with version 4.5.4

  • Resolved gabrielpatzleiner

    (@gabrielpatzleiner)


    Hello,

    first of all, I am using your plugin now for a few months and it’s awesome.

    Today a set up a new wordpress installation with this plugin using a subdomain (blog.example.com). When I wanted to set up the plugin, the API Token domain field is now read-only and it showed “blog.example.com”. After saving the settings I wasn’t able to enable the cache, because cloudflare returned an error (invalid domain name or something like that). It makes sense, because cloudflare needs the top-level-domain (example.com).

    To bypass this problem I just installed 4.5.3. There was already “example.com” in the API Token domain field and I could even change it. Everything works. But I cannot update to the newest version, because of this problem. I hope support for subdomains can be implemented.

    Thanks a lot and greetings
    Gabriel Patzleiner

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    I can confirm the issue. A new release will be released very soon where the readonly will be removed from the domain field so that you can manually fix the domain name as needed.

    The problem is that there is no easy to to get the main domain name from a subdomain name in PHP so, in this case you need to manually enter it.

    A new version of the plugin will be released very soon. Please update to that and it won’t have the readonly anymore.

    Thanks for the feedback.

    Thread Starter gabrielpatzleiner

    (@gabrielpatzleiner)

    Awesome, it works now.

    Thanks a lot for the fast fix!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.