Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Unable to Setup JetPack on my WEbsite

  • Resolved kwiley123


    Hi! I have installed the JetPack plugin on my site, but when I click “Setup JetPack” from the WordPress dashboard, I receive this error:
    Error Details: The registration secrets sent by your site do not match the ones the Jetpack server has on record.

    Please advise as to how I can complete the setup.


    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Stef (a11n)


    Hi there, Sorry to hear about the trouble you’re having!

    Can you please try cycling the Jetpack connection? You can do it by deactivating Jetpack in your wp-admin dashboard at Plugins > Installed Plugins and then reactivating it and connecting to again.

    You may also want to try it on an incognito window of your browser if you see that the same error occurs.

    Let me know how you go!


    We haven’t heard back from you in a while, so we’re going to mark this as resolved. If you have any further questions, please start a new thread.

    Hey guys I am having the same issue, I had jetpack installed and everything was fine and then I disabled the plugin to test for compatibility issues, when I reactivated the plugin I couldn’t set it up. I tried doing it on incognito but I didn’t solve the problem.

    I already deleted and reinstalled the plugin and didn’t work either.

    Any other options I can tried?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unable to Setup JetPack on my WEbsite’ is closed to new replies.