Support » Plugin: Postman SMTP Mailer/Email Log » Unable to send emails when plugin is configured as "Default"

  • In order to check whether my regular PHP mail is no working again, I tried to disable Postman SMTP by setting the Transport Type to “Default”.
    But then, I cannot send any emails anymore. The “Send a Test Email” function reports “No connection could be made because the target machine actively refused it.”

    When I de-activate the plugin, I can send emails, so I don’t think the problem is in WP or in the SMTP server.

    I would like to keep Postman active, because of the email log.

    https://wordpress.org/plugins/postman-smtp/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    You’re not supposed to keep Postman configured with the default settings. Hence all the glaring yellow warnings 🙂

    Are you saying you don’t know what your correct mail settings are?

    If PHP mail accepts your mail without Postman, then your mail settings are hardwired into PHP.ini or similar. I would say for 99.9% of my user base, this is not the case. But I will consider changing the default transport to use PHP mail, just like WordPress does.

    I guess what got me confused was the message “Postman is not configured and is mimicking out-of-the-box WordPress email delivery.”

    I thought: well that’s nice, if I set the Transport Type to “Default”, I get the benefit of the email log function with the standard PHP mail.

    It looks like that assumption was wrong.

    By the way, the Gmail API option works very well.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    You are not the first person with this opinion.

    In my view most people install the plugin because the default configuration (this feature is new with v1.7 – previously Postman simply did nothing until configured) from WordPress does not work. Obviously some people do use WordPress successfully with the default configuration, and want to use Postman for the “extras”. I will change the default transport to use PHP mail for this use case.

    Thank you very much!

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    .. this was a good idea, but I can’t get the SMTP transcript from PHP mail.

    My choices are

    • use PHP mail and show no log
    • use SMTP to localhost:25 and show a log

    Thanks for trying.
    Both choices are better than the current “Default”, unless you document somewhere what “Default” does.
    – SMTP to localhost would not work in my situation, since my SMTP server is not on my localhost. But it might be useful for others.
    – PHP Mail without log is the same as deactivating the plugin, but I like plugins that can be active yet disabled.

    In summary, I am very happy with the way the plugin works, but if you can clarify (or enhance) the Default transport, that would make it even better.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I didn’t mean log… to be more specific, it’s the error messages from the server and the session transcript that I can’t get. I’ll fix it up.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to send emails when plugin is configured as "Default"’ is closed to new replies.