Support » Plugin: Smart Slider 3 » unable to see slider on iphone 11 pro

  • Resolved goodsuccess

    (@goodsuccess)


    Unable to see the slider on iPhone 11 pro max v 14.4

    Using 1 slider and 2 images

    Probably a simple solution but cannot pin-point it down.

    Using the free SmartSlider version.

    • This topic was modified 1 month, 2 weeks ago by goodsuccess.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Gabor

    (@nextendweb_gabor)

    Hi @goodsuccess!

    The problem is caused by the cache/optimization used on your website. The issue can be seen actually on desktop computers too, just the way caching plugins are working is, that they are showing the not-cached version of the website for logged in administrators, while the cached version is shown to logged out users. You are probably logged in, that is why you haven’t noticed the issue there.

    I’m not sure if this will be the main error, but if you right click on your website -> choose “View page source” -> check the very end of the website, you will see this HTML code:
    </body></html><html></html>
    while it only should be:
    </body></html>

    This doesn’t happens without this HTML optimization, what I can see because of another behavior of caching, that when you see a website the first time, it won’t load from cache, only the 2nd time. So if you add a random parameter to the end of your link:
    https://lessonsoflifelc.com/?123
    and take a look, it will be fine first, because it doesn’t load from cache.

    Although I do see, that you have a script after the ending html tag:
    </body></html> <script src="//lessonsoflifelc.com/hashcash.js" type="text/javascript"></script>
    and probably this creates the error in the HTML minification too.

    So I would suggest looking at this first, to try to eliminate this js file from the end of your website, to have it rather before the
    </body>

    or try to turn off the HTML minification of the website. Lastly I also see that Sitespeed JS creates a JS minification, which could also be the cause of the error, so you could try to turn off that as well.

    Thread Starter goodsuccess

    (@goodsuccess)

    I enter the following https://lessonsoflifelc.com/?123 the slider does not show (logged out).

    I deleted the autoptimize cache plugin, and the problem still there. Where does this file </body></html><html></html> reside so I can edit it?

    Plugin Support Gabor

    (@nextendweb_gabor)

    I can see that you are using multiple caching. For example now WP Super Cache is also used, although I do not think the problem comes from that plugin, rather another or it also could be server cache. I suggest going to your Plugins list and deactivate all caching or optimization plugins. If your problem still happens, contact your server host and ask them whether or not you have server caching and ask them to turn it off, because if this is not done by a plugin, only the server could be the cause.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.