• Resolved djranmas

    (@djranmas)


    Basically, I went to Add Galleries/Images, put in a Gallery title, and then clicked on Add images. I saw my folders of where my images are. I created a new folder, hit refresh, and now I can’t see anything at all. My photos are still there, but I cannot see anything in the browser window at all.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support Asya Gabrilyan

    (@asyag)

    Dear @djranmas,
    Thank you for the report.

    Please install Health Check & Troubleshooting plugin to identify any possible conflict with your theme or other plugins.
    Can we have the gallery link please?

    Sincerely,

    Thread Starter djranmas

    (@djranmas)

    I just installed and ran that plugin, and everything turned out to be fine.

    Here’s the gallery link: https://djranmas.net/wp-content/uploads/photo-gallery/

    Plugin Support Asya Gabrilyan

    (@asyag)

    Dear @djranmas,
    You provided your directory link:https://nimb.ws/sDPw9e
    The gallery is displayed here https://djranmas.net/2021/03/15/photoshoot-kagome-higurashi-reflections-of-the-forest/

    Can you please provide a link with the latest gallery?
    Where did you publish it? What page/post please?

    Thank you,

    Thread Starter djranmas

    (@djranmas)

    That’s not the problem.

    The problem is when I go into the file browser to create folders, add photos, and whatnot is blank.

    Here’s a screenshot: https://1drv.ms/u/s!AotB30D6iTXgt7RFCWcSB3-NvrqL7Q?e=aGP1yp

    Right now I can see everything because I rolled back the plugin to 1.5.60. If I upgrade the plugin, I won’t see any of the folders in that screenshot I posted.

    I might have an idea. Reinstall the version of PhotoGallery with the problems. Go to the PhotoGallery filemanager. Although you may not see any content (hit refresh), you can still create directories, but they will not be displayed. Create a directory anyway – hit refresh.
    If you then look into the domain’s error.log at your web host, you should see a big error message. This error message would indicate the problem. Post it here or send it directly to 10Web support.

    Thread Starter djranmas

    (@djranmas)

    I’ve done all of that as well as spoke to my webhoster. He copied and pasted the error.log for you to look at.

    https://pastebin.com/dJkkST3N

    @djranmas
    Good job. I’m not a programmer, but that confirms my suspicion that this may be the same or a similar error as mine. I also have this behavior in my filemanager. When I create a new directory and do a refresh, the view is empty. My server error.log also contains information such as:
    – Unknown column ‘author’
    wp_bwg_file_paths

    I am already in contact with the support because of my error and have now also sent the link to this forum post. Hopefully this will help to fix the bug.

    Thread Starter djranmas

    (@djranmas)

    @detoris Ah gotcha. I thought you were a part of support, but I do appreciate the insight on this. There is another thread with the same issue as well. The plugin was updated, but the same problem exists. I’m going to roll back to a known working version (1.5.60) for the time being.

    @djranmas
    No problem. I hope that the developers can fix the error quickly with our log files.

    • This reply was modified 1 year, 1 month ago by detoris.
    Plugin Support Asya Gabrilyan

    (@asyag)

    Dear @djranmas,
    Sorry for getting back to you this late.

    Please run this query:

    global $wpdb;
    $wpdb->query(“ALTER TABLE ” . $wpdb->prefix . “bwg_file_paths ADD author bigint(20) NOT NULL DEFAULT 1″);

    Sincerely,

    Hello @asyag ,

    I host the site for @djranmas , and when I run the query, I get the following error:

    #1118 - Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs

    After some digging, it turns out that adding this is failing because doing so would exceed the maximum row size of 65,535 bytes. This table already has another bigint(20) along with a handful of varchar(250)’s. I’m seeing that this is a hard data limit for MySQL, despite the storage engine in place. I’m not sure what to suggest, as I do see you have an author bigint(20) field in another table and of course that should match others, but doing so on this table at this point is a technical restraint. Please look into and advise.

    Plugin Support Asya Gabrilyan

    (@asyag)

    Dear @marioknight,
    Thank you for your assistance.

    Would you please run this query?

    global $wpdb;
    $wpdb->query(“ALTER TABLE ” . $wpdb->prefix . “bwg_file_paths ADD author varchar(250) NOT NULL DEFAULT 1″);

    Sincerely,

    @asyag While this would be a band-aid at best, setting this to a varchar(250) still yields the same row size too large error.

    Plugin Support Asya Gabrilyan

    (@asyag)

    Dear @djranmas and @marioknight,
    Please contact our support team using the following form.

    Sincerely,

    Thread Starter djranmas

    (@djranmas)

    Support ticket submitted.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Unable to see photos’ is closed to new replies.