Support » Fixing WordPress » Unable to see or search users

  • I have over 40,000 users in my database. Unfortunately wordpress now does not allow me to search (in the network admin) or browse (choose “all users” in the cpanel) the users in any blog. It will either timeout with a blank page or will yield the error below. I am guessing that it is because there is a join somewhere that makes this slowdown occur. A few years ago someone made a change to the code that seemed to alleviate this problem and I’m unable to determine what they did. Does anyone else have this problem? If so, how have you solved it? Right now I’m getting slow queries and:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 32 bytes) in /home/mysite/public_html/wp-includes/meta.php on line 563

    If you try to browse all users. There isn’t any reason I should require 512MB of php execution memory just do do a simple search of users or to be able to see the first 20 users in my database before performing a search.

Viewing 2 replies - 1 through 2 (of 2 total)
  • OK… this looks like it may have to do with the Orphanage plugin. It may require some type of update because turning that one off seems to make things work, unless there is some cache issue. Odd. Will do some more testing.

    The problem is the multisite user management plugin. It was working with existing blogs. Now if you try to add a new one (and potentially change a permission on an old one), the query hangs and there is an out of memory error that isn’t associated with the php.ini memory setting:

    atal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home/mysite/public_html/wp-includes/meta.php on line 574

    This is now the error with 1GB of memory for execution. Unfortunately there is something wrong with this very important plugin and hopefully I can get someone to take a look at it. I’m sure many would appreciate it (or if someone else beats me to the punch, would appreciate that as well!)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to see or search users’ is closed to new replies.