Support » Plugin: WP Photo Album Plus » Unable to save settings

  • Resolved rosco781

    (@rosco781)


    Hi,

    I am trying to update some of the settings in ‘Table 1: Sizes’ but when i click on the ‘Save Changes’ button nothing happens. If i leave the settings page and go back all the changes i have made have gone back to their original settings.

    This is the line underneath WP Photo Album Plus Settings

    Database revision: 310. WP Charset: UTF-8. Current PHP version: 5.2.17. WPPA+ API Version: 3-1-8-000.

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Is this a new installation or an upgrade of wppa+?

    Do you have enough server memory available? (see table X Php config)

    I would like you to set Enable debugging (Table IX item 5) but if you can’t save it…

    This is a new install, as the website was only started about 4 weeks ago.

    This is a copy and paste of table X – not sure where is says anything about server memory. I am not hosting the site, it is being done through a company called iSOS

    http://pastebin.com/RxwXtqp4

    I have tried to check the ‘Allow WPPA+ Debugging’ but as i expected it did not save.

    I was originally using a plugin called WP Photo Album but when i required sub albums i installed this one as well. When i tried to activate it i was unable to. I deactivated and uninstalled WP Photo Album and then activated WP Photo Album Plus. I was unable to save any settings changes so tried an uninstall and reinstall of WP Photo Album Plus but this did not solve the issue.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    You can not have wp-photo-album and wp-photo-album-plus active at the same time, as the -plus is an upgrade to the first one.

    As a temp solution:
    Try backing up the settings (Table VIII item 4) it makes a file settings.bak in wp-content/wppa-depot/[loginname]/
    If that works, you can manually edit it and restore.

    Please supply a link to the site

    Thanks for the help so far opajaap

    I am unable to select and save the backup option but as i have not done anything that i require yet editing it manually is not a problem.

    I normally use Chrome as my web browser but i tried to do the same think in IE8 and when i click on the settings menu i get a

    Done, but with errors on page.

    When i look at the error it says

    Message: Syntax error
    Line: 247
    Char: 21
    Code: 0
    URI: http://www.wgladiesfc.co.uk/wp-admin/admin.php?page=options

    Could this be causing problems???

    The website is http://www.wgladiesfc.co.uk – This is still very much in design stage and there is nothing i need to editing the settings directly is not a problem as i can always uninstall and reinstall if required

    Thanks for your help opajaap, but i have decided to go down another route using a different plugin.

    Really good plugin though wish i could have been able to update the settings to get the full benefit

    Thanks anyway

    I’m having a similar issue. It’s a fresh install of WPPA+. I do also have NextGen installed at this point. Would there be a conflict there?

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Asking the question is half the answer. Try de-activate NextGen and see what happens…

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    There is a really fair chance that this is fixed in version 4.0.6,
    to be released soon.

    Opajaap I was having this same problem and seeing as this isn’t resolved I’ll make a comment in hopes you can crunch it. Also I’m using Firefox on Linux so might have to take that into consideration too.

    Anyhow I think the problem lies in the jQuery click even to show/hide the table. I couldn’t find the code but I’m going to assume by the way it was acting there was a preventDefault() in there somewhere. That might solve the problem or it might not (block level elements within other block level elements aren’t always the best practice I’ve found out). You could also fix it similiar to how I did. In the page wppa-settings.php down by line 420 you have the entire table heading wrapped within an <H3> tag where I think the root problem lies (in some browsers perhaps anyhow). I got your plugin to work by doing changing this (code truncated):

    <h3><?php _e(); echo(' '); e_(); wppa_toggle_table(); ?>
       <span>....</span>
    </h3>

    to something like this:

    <h3 style="display:inline-block;"><?php _e(); ?></h3> <div style="display:inline-block;"><?php e_(); wppa_toggle_table(); ?>
       <span>...</span>
    </div><br />

    You could also wrap the entire code block in it’s own div but you still have to make the elements inline-block (this should prevent them from breaking up too bad on smaller screens).

    I can now save all my settings and the layout doesn’t change that much (a little more vertical spacing between the tables but doesn’t look bad).

    Hopefully this will help with the issue. By the way – impressive plugin found it incredibly helpful thank you!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Are you up to rev? I changed recently and it should work on firefox, ie and chrome as intented.

    Just downloaded the latest and was encountering the same problem as posted on your forum. Just to be fair I posted it as simply an avenue of possibility on why it wasn’t working. Firefox I have noticed has slight variances on how it works between windows and linux – and linux version isn’t as high as windows either (less fixing on their part).

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    This topic was about unable to save settings.
    There were two reasons in the past:
    1. there was a dubble slash in an admin link that certain systems did not accept. That is fixed.
    2. Insufficient server memory. Anybody can see his server memory amount now in table X.

    There was also an issue on not collapsing tables and lines from tables in chrome. That is also fixed a few revs ago.

    If there is still an issue like described here, i am perfectly willing to fix that, but in that case please open a new thread with a clear description of what is misfunctioning.

    This thread is quite a mess at the moment, i prefer it status remaining Resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Unable to save settings’ is closed to new replies.