Support » Fixing WordPress » Unable to save posts with permalink options

  • In a fresh WordPress installation, I only can save and update posts and pages if permalink option is set to “plain”.
    When try to update I get the red label displayed

    “Updating failed”

    Server is an Apache2 installation.

    I followed all the requirements listed in the documentation.

    FollowSimLynks

    and

    AllowOverride

    are set.

    Fired the rewrite module with

    “a2enmod rewrite”

    .

    .htaccess

    exists, is owned by ‘www-data’,
    I tried the 777 permissions to check,
    I checked that it is edited when permalink option is set in dashboard (I get “Permalink structure updated.” confirmation aswell)…

    My “

    /etc/apache2/sites-enabled/000-default.conf

    ” looks like:

    `<VirtualHost *:80>
    ServerName example.com
    ServerAdmin webmaster@localhost
    Redirect permanent / https://example.com/
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    <VirtualHost *:80>
    ServerName blog.example.com
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html/blog
    <Directory />
    Options FollowSymLinks
    AllowOverride FileInfo
    </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    <VirtualHost *:8019>
    <Location />
    Require ip x.x.x.x/24
    </Location>
    ServerName example.com
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html2/phpmyadmin
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost> `

    What am I doing wrong?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p

    (@t-p)

    I only can save and update posts and pages if permalink option is set to “plain”

    If that works, then try reading Using_Permalinks before setting a custom permalink structure again.

    That’s the same document I read, followed and mentioned in this post. But thanks

    Moderator t-p

    (@t-p)

    If still having issue, this could be attributed to anything from a web server configuration to a bad WordPress install.

    I made lots of installation attempts and “installation” at the end is not much more than a download.
    It is clearly a bug. I have exactly the same behavior in FF than here:
    https://github.com/WordPress/gutenberg/issues/12982
    I tried to follow but not my configuration
    No solution from WordPress so far

    I haven’t worked on Apache conf stuff in a while, but is the first virtual host really needed the one with the permanent redirect? What happens if you take that out or if you try a set up without the blog subdirectory?

    Not necessary for what we are talking about now, you are right. But I need it to redirect to my tomcat server when I have a “normal” visit, and keep it for the php/apache2 when it comes for the wordpress blog.
    I tried for you what you point, but the result is the same even with the working new config.
    But what about the 404 you made me see in the Github thread? Does it mean I should somehow get “wp-json”? How could I do if it’s the case?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to save posts with permalink options’ is closed to new replies.