Support » Plugin: Shield Security - Scanners, Security Hardening, Brute Force Protection & Firewall » Unable to save options for Automatic Updates

  • Resolved Steven

    (@stivnenight)


    Hello,

    I’m struggling with the “Automatic Updates” panel: I can’t seem to save my changes.

    I’d like to turn on and off some features but when I do so and click “save options”, nothing happens.

    The “save options” buttons is working fine on the other tabs though, that’s what I don’t understand.

    Any of you guys have encountered the same issue and know what’s the cause?

    Thanks,

    Steven

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Paul

    (@paultgoodchild)

    Do you know how to check the browser console for javascript errors? If so could you take a look and tell us what you find, please, on that page?

    Thread Starter Steven

    (@stivnenight)

    When I click on Save Options, this is what appears:

    admin.php?page=icwp-wpsf-autoupdates:1 An invalid form control with name=’override_email_address’ is not focusable.

    Does it help?

    Plugin Author Paul

    (@paultgoodchild)

    is it shown as a error (in red usually)?
    Does it happen on other browsers, if not, what is the browser that’s showing the error?

    Also, if you click on the tab “Auto-Update Options” and then try to submit, does it work?

    • This reply was modified 4 years, 6 months ago by Paul.
    Thread Starter Steven

    (@stivnenight)

    Ok I found the bug thanks to your last question. I just had to enter a report email address, with was blank by default… It was kind of unintuitive.

    Plugin Author Paul

    (@paultgoodchild)

    Could you tell me which browser and if it happened on other browsers?

    That isn’t a required field and you shouldn’t be getting stopped from submitting.

    So yes, not intuitive, but also not by design. That isn’t normal browser behaviour

    Thread Starter Steven

    (@stivnenight)

    It was happening on all browsers.
    Yes I know it wasn’t a required fields and that’s why I didn’t have the good reflex to check this. By entering an email address, I could save. I think there was just a letter by default, so neither blank or with an email address, that was blocking everything. But I don’t remember entering anything there, so I don’t know if the letter was there initially or if I have entered one by mistake.

    Plugin Author Paul

    (@paultgoodchild)

    okay cool, thanks for reporting this. We’ll see if we can offset this problem in some way then. I appreciate you working with us to find the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to save options for Automatic Updates’ is closed to new replies.