Support » Plugin: BuddyPress Xprofile Custom Field Types » Unable To Save First Section

  • Resolved ma3ry

    (@ma3ry)


    I am using BP Xprofile Custom Field Types. I have 3 sections including “required”, “optional” and “Seeking Friends or Dating”.

    A new member registered this morning and was unable to save the required info. I tested it and had the same problem, although I can save the other two sections, and I can save the first section as Admin, just not as Subscriber. I created a new test member and have the same problem.

    Can you think of a reason that I can’t save the first section, but I can save the other two?

    Would appreciate any input. I have done a plugin conflict test, used BP repair tools, but not sure what else to try.

    Unfortunately, You will not be able to see a relevant link since my membership is private.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter ma3ry

    (@ma3ry)

    Update: I reinstalled the plugin but still have the same problem. It only affects new members, not existing members.

    Plugin Author BuddyDev

    (@buddydev)

    Hi,
    my apology for the delayed reply.

    The plugin does not handle saving data. It simply registers a field, the saving is handled by BuddyPress.

    It seems to me you might have one of the two issues:-

    1. You have a field marked required in the base group which is somehow hidden by css or some plugin. Please check if there is anything like this?

    2. Or you have a custom field which was marked required bud the field type is not available.

    My suggestion is to check the fields in dashboard->Users->Profile Fields-> Base group and verify that they are available on your registration/edit profile. If not all of them are present, it is the hidden field causing the issue.

    Regards
    B

    Thread Starter ma3ry

    (@ma3ry)

    I understand what you say and it would make sense if the problem affected all users, but it doesn’t. It’s just new registrations.

    It’s OK, I just deactivated/deleted BP XProfile Fields and all is working well. I was really only using it to change birthdate to age. I will try to find a snippet that will do it.

    Thanks for your input.

    Plugin Author BuddyDev

    (@buddydev)

    Hi,
    Thank you for the reply.

    I am sorry you had to remove it. I am not aware of such issue. If you still need to use it, Please provide me the steps to reproduce the issue and I will make sure to update the plugin with a fix.

    Regards
    B

    Thread Starter ma3ry

    (@ma3ry)

    Thank you. I don’t need it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable To Save First Section’ is closed to new replies.