Support » Fixing WordPress » Unable to Save Draft…

  • hi
    I don’t know whats the problem…
    I can’t save any draft. actually, when I click on “save Draft”, an empty draft will save.
    I also Disabled all the plugins and tried again, but it didn’t work
    I’ve also tried with Opera, Fire fox and Chrome …
    Please help me 🙁

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi pichgooshti,

    I assume this has worked correctly for you up until this point?

    Have you tried using a different browser, Internet Explorer vs. Firefox vs. Chrome? It could be an issue with how your browser is dealing with certain javascript code. If you have any plugins for your browser, you may want to try disabling those as well.

    Hi ce_kevinw
    thanks for the response 😉
    there wasn’t any problem till today
    as I mentioned, I tried disabling the plugins and I tried with 3 different browsers.

    help 🙁

    Hi pichgooshti,

    I was actually dealing with this within Joomla the other day. Do you have any special code in your post? What if you try to save a post with simply the word “text” in it, does that work?

    Hi 🙁
    I tried over and over again and finally one post published. but I can’t change it. I also can’t enable comments for this post and I also can’t save any thing in “all in One seo pack”. actually when I click on save, the post doesn’t change at all.
    damn it 🙁
    will this problem solved with reinstalling word-press?

    will this problem solved with reinstalling word-press?

    If the problem is caused by a core WordPress file, upgrading may resolve the issue. If the problem however has something to do with data in the database, it may not.

    Regardless of what you do, be sure to create backups first!

    I am actually trying to help someone with a somewhat similar issue. Here was my hail marry pass to them:

    I’m just thinking outloud now, things I would test.

    The problem is that something as changed, and this changed caused loss of functionality.

    Was it a file that changed?
    Your WordPress files generally don’t change. I’d take a look at the core WordPress files on your account, check the timestamps of when last edited, and see if there is anything interesting there.

    Was it a post that somehow caused the issue?
    If you know the date the issue began to occur, you may want to delete all posts prior to that to see if that is the problem. I would copy the site to a dev server (or just a separate folder) so you don’t mess anything up.

    Thanks – but that was the first thing we tried. I’ve tried it on Chrome & Firefox on Windows 7, and Chrome and Opera on Ubuntu 10.04.

    I know in Firefox that javascript errors are not very obvious, but in Internet Explorer they’re indicated by a yellow triangle. Have you tested in Internet Explorer?

    I don’t get any error messages in the server apache logs or in the javascript console, it just doesn’t take effect.

    To confirm, did you check for any error_log files in your WordPress directory? Sometimes errors are logged there. Each folder can have an error_log file, so you may need to dig around to find it.

    I deleted 2 posts that was published since this issue was occurred. but still the issue is there

    Hi pichgooshti,

    In the previous thread I linked to, the user resolved the problem by running the repair command on each of their MySQL Tables. Can you try that to see if it helps? You may need to contact your host for the steps needed to do it. Here’s a link to an article that has more info however if you’re using cPanel or phpMyAdmin:
    How to Check and Repair a MySQL Database

    Hi ce-kevinw
    I guess I’ve found the problem but I can’t find any way to solve it
    actually by changing my IP address by using a VPN or something, there’s no problem anymore.
    Is the problem referred to ISP or host?

    I had a similar problem with drafts not saving and even published pages not updating. I finally resolved it by looking in my html for none usable text in the javascript pop-up title fields for hyperlinks. A few of mine were way too long. As soon as I went into the html and shortened things, everything became operational again. Hope this helps.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to Save Draft…’ is closed to new replies.