Support » Plugin: WP Crontrol » unable to save custom event

  • Resolved Andrea

    (@licoreo)


    hi,
    i install lastest version of wp crontrol (1.9) then i try to add a custom event, but is not working, there is no error report but the custoom event doesnt appear on list of scheduled event

    i try the 1.8.5 version and it works

Viewing 15 replies - 1 through 15 (of 15 total)
  • Having the same problem on 1.9, unable to add custom event.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Thanks for the reports, I’ll look into this.

    Same issue here, is there any update?

    Same here. I added quite a few custom events in the past, but at this moment it seems to be impossible. No error message, the new event is simply not added to the list.

    Version 1.9.0.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Thanks for the messages. I’m looking into this.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Are you able to provide some more information please? I’ve been testing this locally and haven’t seen any problems.

    * Which version of PHP are you using?
    * Which version of WordPress are you using?
    * Which browser and OS are you using?
    * Are you using the date and time pickers when choosing the time for the event?
    * Are there any errors showing in your PHP error log?
    * Do you have an object caching plugin installed? (eg. for Redis or Memcached)
    * What is your timezone?

    Thread Starter Andrea

    (@licoreo)

    i found the problem in different installation:
    * Which version of PHP are you using?
    7.4.7
    * Which version of WordPress are you using?
    5.6
    * Which browser and OS are you using?
    chrome
    * Are you using the date and time pickers when choosing the time for the event?
    yes
    * Are there any errors showing in your PHP error log?
    no
    * Do you have an object caching plugin installed? (eg. for Redis or Memcached)
    no
    * What is your timezone?
    rome

    * Which version of PHP are you using?
    7.4.6
    * Which version of WordPress are you using?
    5.6
    * Which browser and OS are you using?
    Brave Browser & MacOs Mojave
    * Are you using the date and time pickers when choosing the time for the event?
    No
    * Are there any errors showing in your PHP error log?
    No
    * Do you have an object caching plugin installed? (eg. for Redis or Memcached)
    Redis
    * What is your timezone?
    Asia/Kuala_Lumpur

    kgraversen

    (@kgraversen)

    Hi @johnbillion

    I had this problem – that I could not Add New Cron Event.

    I then tried to comment out the define('DISALLOW_FILE_EDIT', true); in the wp-config.php file.

    And now I can add new events.

    Honestly – I don’t know if that is an actual requirement as I am a new user of WP Crontol. I hope it is not!

    Best
    Ken

    Hi,

    I got exactly the same problem since 1.9.0

    I can’t add any cron event unless I disable the constant define('DISALLOW_FILE_EDIT',true);

    If I disable this constant and add my event, it works. But if I reactivate the constant, the cron Event disappear after a few days…

    It it can help :

    * Which version of PHP are you using?
    7.3

    * Which version of WordPress are you using?
    5.6.1

    * Which browser and OS are you using?
    Chrome / Win 10

    * Are you using the date and time pickers when choosing the time for the event?
    I tried both (run now and to a specific time), same problem.

    * Are there any errors showing in your PHP error log?
    There is no PHP error in the log.

    * Do you have an object caching plugin installed? (eg. for Redis or Memcached)
    WP Fastest Cache, but I tried to disable it, same issue.

    * What is your timezone?
    French. UTC +1

    I’ve run into this same issue and am curious if there’s been any resolution.

    Thanks.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Sorry folks I haven’t had a chance to look into this. I’ll do so within the next couple of days.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Thanks again for the reports everyone. This was indeed related to the DISALLOW_FILE_EDIT constant.

    I’ve released version 1.9.1 which fixes this problem.

    Everything indeed is fine again, thank you!

    Hi @johnbillion

    Thank you for the update.

    Unfortunately there is still some problems with the DISALLOW_FILE_EDIT constant.
    We now can add events, but there I’ve noticed 2 problems :

    -After adding the event, if I run it now, I got an error : The cron event cannot be found.
    -After a few days, the CRON event disappear like the guy on this thread .

    But if I set DISALLOW_FILE_EDIT to false, there is no problem 😉

    I tried both schedule now, tomorrow and a specific date. I although tried several frequency, the problem persists…

    Thanks for your help 🙂

    • This reply was modified 6 months, 3 weeks ago by nartoof.
    • This reply was modified 6 months, 3 weeks ago by nartoof.
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘unable to save custom event’ is closed to new replies.