Support » Plugin: NextCellent Gallery - NextGEN Legacy » unable to rotate pictures

  • Resolved michaelsam

    (@michaelsam)


    hi
    i get the following failure when i try to rotate a picture in any gallery

    Fatal error: require_once(): Failed opening required ‘NGGALLERY_ABSPATH/lib/image.php’ (include_path=’.:/usr/share/pear’) in /ROOT/PATH/TO/SITE/wp/wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/manage/actions.php on line 9

    do you know how to solve this ?

    michael

Viewing 8 replies - 1 through 8 (of 8 total)
  • by the way i’m using php 7.1 if this helps to solve this.

    Plugin Author WPReady

    (@wpready)

    I’m unable to reproduce the problem, so far I tested rotating the pictures without incidents (using PHP 7.1.1).

    There is something deeper, since NGGALLERY_ABSPATH should have the proper value, and in the error this constant is not working.

    Do you have any unusual WP configuration?

    thx for your answer
    i don’t think so. tried it also on another domain, but same provider
    also with different php versions, but always get the same failure
    the constante i checked and it seems to work right
    [NGGALLERY_ABSPATH] => /ROOT/PATH/TO/SITE/wp/wp-content/plugins/nextcellent-gallery-nextgen-legacy/
    i also deaktivated all plugins, same result
    reinstall of plugin also didn’t work
    also install on a subdomain, where it never had been installed also didn’t work right.
    so i will ask the provider, probably they have an idea.

    Plugin Author WPReady

    (@wpready)

    Nextcellent is using an ‘illegal’ way of making WordPress core calls (illegal because all plugin authors using this shortcut are called to fix it).
    Sadly, that was ‘fixed’ disabling some features in 1.9.32. It seems your problem is related to this incident.

    For the moment I’ll recommend going back to 1.9.31 until 1.9.33 is published. I’m making efforts to correct those things in the next release with an ETA next week.

    Previous version of Nextcellent
    https://wordpress.org/plugins/nextcellent-gallery-nextgen-legacy/advanced/

    thank you very much
    i will wait for new version and tell you, if then all is working right

    Plugin Author WPReady

    (@wpready)

    After some digging I found that this plugin has at least 5 illegal calls to WordPress core, due incorrect legacy code involved. That means I need to fix all this invocations because this way of coding is now forbidden in the repository (and I agree with that).

    Those changes implies an important core rewriting. I guess If I solve one , I will solve the others quickly. The good side of this story is the plugin will work faster and lighter. But it’s going to take a lot of work.

    I don’t think it will be a 1.9.33 , more likely 1.9.4 since there are many improvements around it.

    Wish me luck…

    thx for solving

    Plugin Author WPReady

    (@wpready)

    I’m glad it work…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘unable to rotate pictures’ is closed to new replies.