Support » Plugin: WEBphysiology Portfolio » Unable to retrieve thumbnail from ShrinkTheWeb.com

  • Resolved Sören Müller

    (@pattyland)


    Hi,

    I just installed your plugin and try to use STW to generate my thumbnails, but I keep getting the error “Unable to retrieve thumbnail from ShrinkTheWeb.com”

    The answer from stw is “invalid credentials”, although I print out $request_url from stw.php and tried in my browser, where it works fine…

    Any idea what’s going wrong?

    Greets, pattyland

    http://wordpress.org/extend/plugins/webphysiology-portfolio/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Lambert

    (@lambje)

    Did you enter the STW Access Key and Secret Key into the Portfolio Options? Mine’s working fine.

    Cheers,

    Jeff

    Hi Jeff,

    yes! I found the problem.

    In line 234 in stw.php you use http_build_query without any parameter. The default arg_separator on my server seems to be “&amp ;” (the space is only because the forum translates it otherwise 😉 ) , which leads to a broken request to stw!

    I changed the line to:
    $request_url = "http://images.shrinktheweb.com/xino.php?".http_build_query($args, '', '&');
    which fix my problem.

    Greets, pattyland

    Plugin Author Jeff Lambert

    (@lambje)

    Pattyland,

    Glad you got it working. I’ll take a look at this code but no one else has noted a problem. Sounds like I might need an option to set it for these rare cases, eh?

    Glad you figured it out and thanks for sharing what you found.

    Jeff

    I don’t think that there is need for an option, just set this parameter always to “&”, in case the default parameter is something else 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to retrieve thumbnail from ShrinkTheWeb.com’ is closed to new replies.