Support » Plugin: Google Listings & Ads » Unable To Retrieve Site Verification Token

  • kkhs

    (@kkhs)


    Stuck at step 1 of setup. Unable to proceed.

    Keep getting Unable To Retrieve Site Verification Token message and can not connect Merchant Center account.

    See below for the error message I get in the log every time I click Connect. The WooCommerce site itself is live, not passworded, and functioning 100% so not sure where the 403 happens.

    Have an existing Merchant Center account. Site is verified and claimed as instructed by Google and Google shows the two green checkmarks for the domain.

    Have tried to connect the Merchant Center account multiple times. Even created a new account with the “Or, create a new Merchant Center account” option. But keep getting the same error below.

    2021-06-23T20:11:57+00:00 ERROR Automattic\WooCommerce\GoogleListingsAndAds\API\Google\SiteVerification::get_token {
      "error": {
        "code": 403,
        "message": "Request had insufficient authentication scopes.",
        "errors": [
          {
            "message": "Insufficient Permission",
            "domain": "global",
            "reason": "insufficientPermissions"
          }
        ],
        "status": "PERMISSION_DENIED"
      }
    }
    • This topic was modified 2 months, 4 weeks ago by kkhs. Reason: Got it to work with a manual database change. Updated my review to 3 stars as I believe the plugin should provide clearer error messages
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jason a11n

    (@jconroy)

    Hi @kkhs,

    Thanks for opening a topic/review and sorry to hear about your difficulties.

    Just wanted to confirm
    * You connected the site to WordPress.com ok
    * You connected the site to Google ok
    * You are unable to connect a Merchant Center account from the provided drop-down list

    Is that correct?

    Could you please check for me what role/permissions the Google account you have connected has to your merchant center account? https://d.pr/i/hrJA7K – It will be under Account Access https://d.pr/i/emEn1O in the Merchant Center dashboard.

    One thing I would suggest is disconnecting and reconnecting the google account. I think you’d be able to disconnect from the settings page by manually browsing to..

    /wp-admin/admin.php?page=wc-admin&path=%2Fgoogle%2Fsettings

    And then try reconnect.

    Thread Starter kkhs

    (@kkhs)

    @jconroy,

    Thank you for your reply!

    I did indeed confirm my role to be Admin as I suspected it was a permissions issue on that side.

    Because I needed to resolve the issue in a hurry, I looked at the php code to see how the plugin was handling the verification and actually ended up manually inserting the correct site verification meta tag in the database.

    I was then able to proceed through the rest of the steps and everything appears to be functioning correctly today.

    You sent me that manual link to disconnect the accounts. I was actually baffled that I could not (seemingly or obviously) do that directly from the UI as that was the first thing I looked for. Maybe add that as a feature for anyone who accidentally starts the process with a wrong account?

    Thanks!

    Plugin Support B C. a11n

    (@battouly)

    Hey @kkhs,

    I’m glad to read you were able to sort that out.

    As for the suggestion, It would be great to have you add your ideas to the [Ideas Board](http://ideas.woocommerce.com/forums/133476-woocommerce), which is where developers go to look for future plugin features and improvements.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this review.