Support » Plugin: OneSignal - Web Push Notifications » Unable to push posts, receiving errors since last update!

  • Hi there,

    The recent update to the onesignal wordpress plugin has broken our ability to push posts. We receive an error that says wordpress unable to contact onesignal.

    We depend on onesignal and this is an urgent matter for us. Thanks for your help.

    Cheers,
    Blake

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author OneSignal

    (@onesignal)

    Howdy,
    Could you please take a look at our previous response here?

    Hi there,

    We did a bunch of testing and the issue is Gutenberg. The onesignal plugin is not working for people who don’t use Gutenberg.

    Is it possible to fix this?

    Thanks for the help.

    Cheers,
    Blake

    FYI, it’s not working correctly with Guttenberg either. I took a small post that I’ve scheduled for Friday, July 26, 2019, hit Save Draft and Voila! One Signal sent a notification on a Draft. I am signed up for notifications in my browser, so I saw it right away.

    Also, we rolled back to previous versions of the plugin and it still did not work with Gutenberg disabled.

    Looking at this support forum and twitter, we’re not the only ones with issues.

    Here’s an image of what we saw in the debug… we get this error when trying to push while publishing a post, scheduling a post, and updating a post:

    https://drive.google.com/file/d/1Q9Ki2Pr4v_Xn9t1ZbNrQk8tNgtjuIojX/view?usp=sharing

    Thanks again for the help.

    Cheers,
    Blake

    • This reply was modified 2 months, 4 weeks ago by  xjamasterx.

    Enabling Gutenberg and the Classic Editor plugins at the same time fixed the issue.

    We are now able to push posts.

    However, when we schedule a post and check the “Send notification on post publish” box, the box remains unchecked after we click “Schedule.” This makes it look like it’s not scheduled to push.

    Thanks.

    Cheers,
    Blake

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.