Support » Plugin: Smart Grid-Layout Design for Contact Form 7 » Unable to Publish Form, Save Draft, or See text view

  • Resolved teiheim

    (@teiheim)


    On the backend, when using Contact Form 7 I have been using the plugin for a few days and now I am unable to save or publish my form, I cannot even see the text view In the console I get the following errors:
    -Uncaught TypeError: CodeMirror.overlayMode is not a function
    -Uncaught Error: cannot call methods on tabs prior to initialization; attempted to call method ‘option’

    I have not added any new plugins since adding Smart Grid-Layout Design for Contact Form 7.

    • This topic was modified 1 year ago by  teiheim.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Aurovrata Venet

    (@aurovrata)

    that’s odd. One of the javascript libraries is probably missing/not loading.

    Could you unsintall + delete the plugin and download/install a fresh copy to see if it fixes the problem?

    Plugin Author Aurovrata Venet

    (@aurovrata)

    any luck fixing your issue?

    Plugin Author Aurovrata Venet

    (@aurovrata)

    I am assuming this is now resolved since you have not got back on this issue.

    I am having this same issue and I just downloaded that plugin…..

    It’s strange, under the grid is a big yellow box and the “Grid” and “Text” are on the far left, not like I’m seeing in tutorial videos…

    What do you think is wrong?

    Plugin Author Aurovrata Venet

    (@aurovrata)

    The javascript is failing. Likely due to a javascript file load error or an error on the page from another plugin.

    What does your console report?

    You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors.

    We have been trying to get one of the fields in the form to auto-fill addresses….

    Oops?

    Deactivated the API… still not working.
    Console:
    JQMIGRATE: Migrate is installed, version 1.4.1

    Plugin Author Aurovrata Venet

    (@aurovrata)

    Indirect your network tab in your console and check for any 404 loathing errors.

    Oh wow this is what I’m getting in the console……
    I’m sorry it’s just a bit hard to follow your code, I’ve been trying to read through it.

    Uncaught TypeError: CodeMirror.overlayMode is not a function
    at cf7-grid-codemirror.js?ver=2.5.4:32
    at Tt (hesh.min.js?ver=2.2.5:1)
    at Si (hesh.min.js?ver=2.2.5:1)
    at Ai (hesh.min.js?ver=2.2.5:1)
    at new ka (hesh.min.js?ver=2.2.5:1)
    at ka (hesh.min.js?ver=2.2.5:1)
    at HTMLTextAreaElement.<anonymous> (cf7-grid-codemirror.js?ver=2.5.4:56)
    at HTMLTextAreaElement.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:3)
    at HTMLTextAreaElement.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:3)
    at Object.trigger (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:3)

    And when I try to Publish I get this…

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:2 Uncaught Error: cannot call methods on tabs prior to initialization; attempted to call method ‘option’
    at Function.error (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:2)
    at HTMLDivElement.<anonymous> (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load[]=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load[]=,underscore,word-count,post,svg-painter,wp-auth-check,jquery-ui-tabs,thickbox,editor,quicktags,jquery-query,admin-comments,wp-ut&load[]=il,dashboard,jquery-ui-draggable,backbone&ver=4.9.8:34)
    at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:2)
    at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:2)
    at a.fn.init.a.fn.(/wp-admin/anonymous function) [as tabs] (https://nassaucountytherapist.com/wp-admin/load-scripts.php?c=0&load%5B%5D=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load%5B%5D=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load%5B%5D=,underscore,word-count,post,svg-painter,wp-auth-check,jquery-ui-tabs,thickbox,editor,quicktags,jquery-query,admin-comments,wp-ut&load%5B%5D=il,dashboard,jquery-ui-draggable,backbone&ver=4.9.8:34:1857)
    at HTMLFormElement.<anonymous> (cf7-grid-codemirror.js?ver=2.5.4:287)
    at HTMLFormElement.dispatch (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:3)
    at HTMLFormElement.r.handle (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9.8:3)

    Plugin Author Aurovrata Venet

    (@aurovrata)

    Yes this is what i feared. Some js libraries are not being loaded properly. This could be due to multiple reasons.

    When you open your console to check for js errors you’ll see a ‘Network’ tab. Open it and reload the page and filter the js files. See if any are returning 404 errors.

    I’ve got same problem, err from console:

    Uncaught TypeError: CodeMirror.overlayMode is not a function
        at cf7-grid-codemirror.js?ver=2.8.0:32
        at Function.CodeMirror.getMode (codemirror.js?ver=5.5.0:5429)
        at loadMode (codemirror.js?ver=5.5.0:236)
        at attachDoc (codemirror.js?ver=5.5.0:7657)
        at new CodeMirror (codemirror.js?ver=5.5.0:107)
        at CodeMirror (codemirror.js?ver=5.5.0:60)
        at HTMLTextAreaElement.<anonymous> (cf7-grid-codemirror.js?ver=2.8.0:56)
        at HTMLTextAreaElement.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,wp-a11y,u&load[]=nderscore,jquery-ui-tabs,wp-pointer&ver=5.1.1:3)
        at HTMLTextAreaElement.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,wp-a11y,u&load[]=nderscore,jquery-ui-tabs,wp-pointer&ver=5.1.1:3)
        at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,wp-a11y,u&load[]=nderscore,jquery-ui-tabs,wp-pointer&ver=5.1.1:3)

    This is failing inside cf7-grid-codemirror.js on line 32

    I’m not getting any 404 errors on resources under network, CodeMirror.js along with cf7-grid-codemirror.js is loading correctly, but CodeMirror.overlayMode returns undefined.

    As I’m looking on what’s loading, there is conflict, beacause Toolset Types plugin is also loading codemirror.js

    Plugin Author Aurovrata Venet

    (@aurovrata)

    Oh, that makes sense! Thanks for the insight, I will look at this issue in the next release.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.