Support » Fixing WordPress » Unable to Publish, edit, or delete a post.

  • I’ve seen other threads about this problem but yet to find a cure. Let me explain what happened:

    – I imported my tumblr posts to my wordpress just to see if I was able to… for future reference. And it worked — BUT I noticed I was unable to delete any of them from my WordPress.
    – I logged into phpMyAdmin and deleted the tumblr posts manually from my WordPress MySQL.
    – This is when I noticed that I was unable to post or publish anything on WP. I’m not sure if this occurred BEFORE or AFTER deleting the tumblr posts manually — but I didn’t notice it til afterward.

    I have spent the past two days troubleshooting. This is what I’ve done so far:

    1. Made sure I’m still an admin on WP — I am. I even checked the coding in MySQL — everything seems correct. I’ve been using my husband’s WP database as a reference, as his is working fine.
    2. I made an entirely NEW wordpress account in a new database. I’m using Twenty Eleven theme, no plug-ins. And it works fine UNTIL I import my old wordpress posts over. Clearly there is something wrong with my old database. I’ve tried at least 3-4 different types of ways to import my old files over — and everytime it messes up and I’m unable to delete, edit, or publish a post.

    Something clearly went wrong when I either imported tumblr posts or deleted them manually. I’m pretty sure it’s the tumblr posts (other people have been having issues with this)…

    I’m hoping I don’t have to create & use a new WordPress. I hate to lose all my old posts. Any one know of any other options? I feel like I have tried just about everything I can think of.

    ** I am using an older version of WP. I downgraded from 3.2.1 to see if that was an issue — it wasn’t.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Might be worth exporting your posts out to a and tick the import images box, then setup a new blog and return them back to your blog rather than spending ages trying to fix it.

    Is it not allowing you to post or not saving when you post, i.e. does it seem like you don’t have permission?

    Thanks, Tom. I created a blog and am now importing my old posts. It’s processing now. We will see how this works out. πŸ™‚

    And yes, it does seem like I do not have permission to delete, edit, or make new entries. Let me explain this as well: I AM able to create posts but each time I submit them to be published they are saved as drafts (in WP version 3.0) if I do the same thing in WP version 3.2.1 it says I’m submitting for review.

    You attempted to edit a post that doesn’t exist. Perhaps it was deleted?

    That’s the error I get when trying to edit the “drafts” I have made after the whole mess-up.

    I am, however, able to edit all the posts I’ve made PRIOR to WordPress messing up on me.

    I’m just not able to delete the drafts I’ve made nor make publish anything new. 😐

    Hmm. So I created a blog and imported all of my old posts/comments/pages to that one and it worked. I was able to delete posts, edit them and also Publish new ones.

    However, when I exported the posts from the blog to import on my Website-based blog… the same issues occurred. I’m not able to delete, edit, or publish anything. 😐 This is so weird.

    How did you import your tumblr post to WordPress? Check this out for a comprehensive way to import Tumblr to WordPress..

    That’s exactly how I did it, Richard.

    I did that exact way and i am able to publish or edit my post. I guess we’ll have to wait for others for some solution. I m sorry that i can’t help you

    Okay sorry if I wasn’t clear, once you move them out to you need to archive (or delete) your old site files, and database and install WordPress fresh, then return them back and you should be okay.

    I did that very thing, Tom. I deleted my database & installed an entirely new Word Press on a new database. 😐

    It’s strange — because they worked fine on the blog. No errors that I noticed. But when I imported them to a server based WP, that’s when it messes up. I thought it was the database but I created an entirely NEW one. I wonder if it’s the Importer Plug-in I am using. (I’m using the one that WP recommended under Tools > Import.

    *** Update ***

    Okay… the problem is DEFINITELY in my posts that I’m trying to import. I made an entirely new Database & Test WP where I imported my husband’s posts over. I had no issue — I am able to edit & delete them as well as create new blog posts. So something is definitely wrong with my blog posts. πŸ™

    I think I may have fixed it… somehow!

    I made a new database & wp blog. I imported my husband’s posts to see if it may have been my post entries that was messing it up. And his posts worked! I could edit, delete & publish new posts. Everything seemed to work fine. So… I imported MY old posts as well to see what would happen. And it worked! Everything seems fine now.

    BUT — I must mention. Before I exported my old files I did a little cleaning up first. I logged into MyPhpAdmin and took a look at my wp_posts table in my WordPress Database. I noticed A LOT of “drafts” that were basically empty. I deleted all of them. I then logged into my wordpress and exported all my files. Once I imported them to my NEW WP, everything was fine.

    So I’m guessing my wp_posts table just needed to be cleaned up a little? /shrug — but everything seems to be fine now — woot! πŸ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to Publish, edit, or delete a post.’ is closed to new replies.