Support » Fixing WordPress » Unable to post comments

  • I am unable to post comments on my blog. I was testing the “Comments” feature and I am now unable to post. Once I attempt to add the comments and hit the submit button, nothing happens. It’s almost like clicking the “POST COMMENT” button does not work. I’ve tried removing a few recently installed plug ins but still nothing. I can ad comments if I am logged into the website editor, but not directly on the website (as a logged in user or logged in admin).
    I also tried updating the version of wordpress & the version of my theme…… nothing

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello from another Toledoan!

    The main issue — your site seems to require login to post commets.

    I can’t really test. Can you see what URL your site tries to go to when you hover over the Post Comment button? Maybe right click, copy/paste here?

    Sometimes, it’s as simple as going to your settings->permalinks page and hitting save. That refreshes your permalinks and sometimes sorts out this issue

    Have you made any configuration changes since you could post comments?

    The common troubleshooting steps are to disable all plugins and test your site, then to switch to 2012 theme momentarily and test site. This narrows down possible conflicts

    Google chrome would not show me url when i hover over button, explorer did….. but i also noticed the comment box was not formatted properly while on explorer. I will temporarily change my setting so you don’t have to be logged in to leave a comment

    Yikes! Feel free to go delete my comment.

    I obviously was able to leave a comment!

    Have you tested in other browsers or machines to try to narrow this down a bit?

    I see you are using the jetpack commenting feature – which I’m not too up on… I just started playing around with it myself. Also, Jetpack looks a little jacked up on my site too ( using IE.

    The one thing about jetpack is that it can easily have conflicts with other plugins, since it does so much. And it can conflict with a theme too depending how they implement their default comment form. And if anything tries to bring in it’s own version of jQuery that is likely to screw with jetpack… I’m gonna peep your site now for any hints of that.

    Update: no extra jQuery in there that I see. So it seems like it’s either machine/browser specific on your end, or it only happens when you have your configuration set to require login.

    I would test on another machine/browser without requiring login to see if you can comemnt. Then set it back to requiring login and test from another machine/browser.

    weird….. I can comment now too. it obviously has something to do with the requirement of being logged in to post

    i’ve tried it on several other machines / browsers. No luck (until removing logged in requirement)

    Now that you can pinpoint your problem with some celerity, I’d recommend describing your exact problem on the Jetpack specific forum to see if you can get more knowledgeable input – I haven’t tinkered enough with Jetpack to know it’s inner workings yet!!

    Hopefully one of their folks can help you further!


    Even if I log in, I cannot post a reply via the public blog page.

    I disabled the “Jetpack Comments” feature, and that resolved my problem in all browsers. I left the other Jetpack features that I wanted activated.

    This situation occurred using the latest release(s) of WordPress and the Jetpack plugin. The theme is twentytwelve.

    It seems odd that such an integral feature will not work (for me), but I am new to WordPress.

    I just wanted to let folks know what I am experiencing.

    Any suggestions appreciated.

    Thank you and all the best.


    It would be best to open a new topic if you need further assistance on your problem. Even though your problem appears similar, it could be quite different.

    As for the jetpack comments – I use them on a 2012 theme based site and they do work. There must be something more to your issue.

    @rev. Voodoo

    Thanks for the advice to a newbie. I will open a new topic, if I can’t figure it out myself.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Unable to post comments’ is closed to new replies.