Support » Plugin: WordPress Download Manager » Unable to override page template after update

  • We used to override the download page template by including this directory/file in our theme:

    /mytheme/download-manager/page-template-default.php

    This no longer works. I can’t find any documentation on how to accomplish this. Can you please advise? Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Shafaet Alam

    (@shafayat-alam)

    Hi,
    We are checking the issue, it will be okay from the next update

    Plugin Contributor Shafaet Alam

    (@shafayat-alam)

    Please use like this:
    /mytheme/download-manager/page-templates/page-template-default.php

    Thread Starter ninanmnm

    (@ninanmnm)

    Hi there, thanks for the quick response. I updated the plugin and set up the directory like you suggested but it’s still not working for me..

    https://imgur.com/a/KMEQEEI

    the page in question: https://pime.staging.wpengine.com/download/2021-summer-fall-webinar-education-schedule-july-dec/

    Our template uses a table instead of unordered list, so those bullet points and some of the styling should be different. Also we don’t display the Description section.

    When I preview the template from the admin templates setting page it’s correct.

    Plugin Contributor Shafaet Alam

    (@shafayat-alam)

    https://pime.staging.wpengine.com/download/2021-summer-fall-webinar-education-schedule-july-dec/ it is not the original Default Template ( page-template-default.php ), you are using there is Single Column, Flat ( page-template-1col-flat.php ), so, you need to copy that file and edit, you change the page template to “Default Template” from package settings.

    Thread Starter ninanmnm

    (@ninanmnm)

    Hi again, sorry, I think we might be misunderstanding each other. Let me try another approach: the plugin offers multiple templates for the Download page. Let’s say I don’t want to customize anything, but I just want to use a different template that is provided. Where/how do I choose the template? I can’t seem to find that setting.

    Thanks for your help!

    Thread Starter ninanmnm

    (@ninanmnm)

    Never mind, I found it! 🤦‍♀️ I didn’t realize our client was choosing the “Single Column Flat” template. That explains everything. Thanks for your help, I should be able to figure it out from here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.