Unable to migrate Permalinks - Please Help! (4 posts)

  1. pcpoet
    Posted 9 years ago #

    I installed my WordPress 2.1.3 blog almost ten weeks ago without any hiccups and it has been smooth sailing from the outset. Here it is. I'm using a theme and a number of plugins too which have had no conflicts.

    What I was ignorant of from the outset was permalinks, though now I have a good idea what they're about and as many others have found, the default 'ugly' sequence is detrimental to SEO.

    No matter what I do to migrate my permalinks to any other structure, I get a 404 error or something similar. My ideal sequence is is /%category%/%postname%/ or /%postname%.htm. I've tried to use deans_permalinks_migration_v1.0 and permalink_redirect-0.7.0 in every possible order of installation with the same results.

    I have read every post on the issue and tried every possible solution I can find. My host Unix server allows writing to the .htaccess file, with CHMOD 666 etc, which I have also been able to edit directly with Redirect 301 commands and any suggested coding from forums and support blogs, alas, to no avail.

    I would appreciate any help I can get.

  2. BlueLaw
    Posted 9 years ago #

    Sounds like you and I have exactly the same problem... The adress endings are changing to your new permalink structure, but your pages remain in the same place, thus giving you the 404 error.

    It's a nightmare, I can't believe I can't sort this. You got any further with it?


  3. BlueLaw
    Posted 9 years ago #

    Bizarrely, I’ve managed to sort this problem for myself – to a satisfactory standard anyway.

    Choose the custom permalink structure and type this:


    And it works! – it’s not perfect but it’s good enough, play about with it.


  4. pcpoet
    Posted 9 years ago #

    Thanks BlueLaw

    Doesn't work on mine. I tried and all I get with that is:

    "Internal Server Error, this is an error with your script, check your error log for more information."

    The error log then says the link(s) did not exist.

    Back to default again.


Topic Closed

This topic has been closed to new replies.

About this Topic