Support » How-To and Troubleshooting » [Resolved] Unable to make/delete/edit posts while admin

[Resolved] Unable to make/delete/edit posts while admin

  • All of a sudden I am unable to make any new posts while logged in as admin. The submit button is gone and is only showing “Submit for review” and when I press it I get an error saying “You are not allowed to edit this post.” This also happens when I try to edit and delete old posts. I’ve read similar topics on this forum and I have tried basically all of the solutions that were posted. I’ve tried:

    -Reinstalling wordpress.
    -Making a new admin user to demote the original admin and promote him to admin again.
    -Removing all drafts and empty posts in the database.
    -Resetting the auto_increment in the database.
    -Deactivating all plugins.
    -Checked storage limit in database/ftp (it’s unlimited).

    Any suggestions?
    I’m tempted to modify the php scripts just to get rid of this ugly error.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Bump.
    This is important, as the site is a live production site.
    Someone must have had the same problem.

    Try to add the role to the admin user may be.
    `$role = get_role(‘administrator’);

    Look into Roles and Capabilities for more info.

    Try to add the role to the admin user may be.

    $role = get_role('administrator');

    Can I add this to the wp-settings script?

    Moderator kmessinger


    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    – resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.


    As I explained in my post: I have tried all that, yes.
    I’m going to try and reset the plugins though. Will let you know what happens.

    Nope that didn’t work. Think I’m gonna re-install clean with a new database.

    Sorry for the triple post but I’ve located the error. I tried switching database and the publish button appeared again. Now I just have to find the faulty database table. I suspect it is the wp_posts table.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Unable to make/delete/edit posts while admin’ is closed to new replies.