• Hi,

    I’m currently using the Ultimate Members plug-in on my association’s WordPress website.

    Despite the fact that the login process works perfectly well, when I try to logout from the site, there is no other option than delete the cookies.

    That problem is only recent and was reported from one of our customers. It becomes impossible to logout from the account using

    the logout link from the menu

    https://___.fr/user/logout/

    or even the logout link from the black admin bar

    https://___.fr/wp-login.php?action=logout

    This happens even if I deactivate all other plug-ins and disappears when I disable the UM plug-in.

    I made a quick inspection of the UM’s logout function file and everything seems legit.

    Of course, I use the last update (Version 1.3.88) of UM and WordPress.

    Can you help me please ?

    Cordially,

    Alex

Viewing 14 replies - 1 through 14 (of 14 total)
  • HAd same issue, it was the UM Terms & Conditions Plugin

    Thread Starter Alexandre

    (@nasmi3)

    Did you find the exact origin of the problem ?
    I mean which part of the plug-in was responsible for that.
    I don’t have any extension installed for Ultimate Member and the problem occurs even with the base plug-in only…

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @nasmi3,

    Have you tested this issue on the default WordPress theme?
    Do you have any caching plugins installed or server side caching active on your site?
    Please exclude Ultimate member pages from the cache and see if this helps.

    Regards.

    Not sure if this will help you or not, but I just had this issue myself…. I was using a custom login url plugin that allowed me to choose the links to login, logout, lost password, etc… and my custom logout link was blank – so it would go to the homepage and not logout.

    Thread Starter Alexandre

    (@nasmi3)

    Hello @ultimatemembersupport

    Even with the cache deleted and no caching plugin with the Twenty Seventeen theme activated nothing changes, it continues to redirect me to my profile page.

    I really like your plug-in and our users love to have some private sections on the website just for them so I don’t want to deactivate it.

    Thanks for your quick answer !

    Regards.

    Thread Starter Alexandre

    (@nasmi3)

    Hi @rexwilliamson,

    Unfortunately, the bug appears even if UM is the only active plugin. I think that the problem comes from the plugin itself.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @nasmi3,

    Can you please check developers console of your browser for errors.
    Please also check error.log file of your server and let us know if you see any errors there. If you are not sure where to find your error log file, please contact your hosting provider and ask for help.

    Regards.

    Thread Starter Alexandre

    (@nasmi3)

    Hello,
    I had to wait 24 hours in order to be sure that the logs will be complete.

    Here is what mw browser’s console say :

    [Violation] Added non-passive event listener to a scroll-blocking 'wheel' event. Consider marking event handler as 'passive' to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952
    Linked with JQuery
    Same error with the "touchstart" event

    With the server web log :

    78.___.163.168 ____.fr - [04/Nov/2017:18:49:11 +0100] "GET /user/logout/ HTTP/1.1" 302 27 "https://____.fr/wp-admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    78.___.163.168 ____.fr - [04/Nov/2017:18:49:18 +0100] "GET /user/ HTTP/1.1" 302 27 "https://____.fr/wp-admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    78.___.163.168 ____.fr - [04/Nov/2017:18:49:21 +0100] "GET /user/nasmi3/ HTTP/1.1" 200 14741 "https://____.fr/wp-admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"

    And with yesterday’s error log :
    [Fri Nov 03 22:45:42 2017] [error] [client 91.___.248.253] [host ____.fr] client denied by server configuration: /homez.66/_____/www/.user.ini, referer: https://____.fr/.user.ini

    Regards.

    @ultimatemembersupport – I’m having the exact same issue as @nasmi3. Latest WordPress update and UM version 1.3.88…

    Thread Starter Alexandre

    (@nasmi3)

    @cdotm , @ultimatemembersupport
    I might have found something !

    Does your log-out page have a parent page ? If so try to have it un-parented.

    @nasmi3 No parent page…

    I’ve just fixed the issue on WP 4.9.3 + UM 1.3.88 with Alexandre’s receipt.
    Need to unlink from parents all pages involved in authorization scenario (login,logout,user,users,profile,recovery,register). In page’s properties->parent->set main page(no parent). Hope it helps.

    None of the above worked for me, but I tried this…

    Go to UM/User roles/log out options/
    Action to be taken after logout – go to custom URL

    and set url as main website address.

    That worked fine!

    I had the same issue and it could be related to WooCommerce. This solution worked for me…

    Go here (replacing yoursite.com):
    http://www.yoursite.com/?customer-logout=true

    Found here:
    https://wordpress.org/support/topic/logout-link-no-longer-works/#post-4611580

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Unable to logout from the website’ is closed to new replies.