Unable to login via admin - "Cannot modify header information" - pluggable.php (4 posts)

  1. triefy
    Posted 4 years ago #

    This is the 2nd time this has happened to me within a week and I'm not sure if my site's being hacked or what.

    When I go to sign-in (http://www.destroythebrain.com/wp-admin), I get text displayed "Warning: Cannot modify header information - headers already sent by (output started at /home/content/t/r/i/triefy/html/wp-includes/pluggable-deprecated.php:1) in /home/content/t/r/i/triefy/html/wp-includes/pluggable.php on line 881" and do not have the ability to sign in.

    This happened on Wednesday and I uploaded WordPress again & even upgraded, now I'm in the same boat I was. Any suggestions? I can reupload WordPress again, but there has to be something that is causing this.

  2. rcbaguio
    Posted 4 years ago #

    Also cannot login (http://rcbaguio.org/wp-admin). Am also very suspicious that my site is being hacked.

    I am getting a very similar error message; with the "Warning: Cannot modify header information - headers already sent by..." coming in as the fourth line error.

    To triefy: I have just tried to log-into your site and wp-admin suffix already works. Your site is now working properly. If you have worked out a solution, please do share it with me. I will be very thankful.

  3. rcbaguio
    Posted 4 years ago #

    Was finally able to resolve the problem and in the process learn more about using an alternate approach for the /wp-admin suffix.

    The solution is to issue a variant of the /wp-admin access, by-passing all of the errors. This can be done by using: http://www.mydomain.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.mydomain.com%2Fwp-admin%2F&reauth=1. In my case, it was http://www.rcbaguio.org/wp-login.php?redirect_to=http%3A%2F%2Fwww.mydomain.com%2Fwp-admin%2F&reauth=1. This allowed me access to the WP Log In, just like there were no errors.

    As I logged-in, the first three errors which were causing the inability to log-in again were displayed-- in the WordPress backend. In my case it was the misbehaving staff-directory plugin. Further investigation proved that it was indeed the plugin--or probably some incompatibility with the theme I was using. Deactivating the plugin made the three error messages go away; so it is conclusive that the errors were being caused by the plugin.

    Now I know the solution to any wordpress site that misbehaves (won't allow log in access to the WP backend) when using the /wp-adin suffix is the simple use of the above-given "by-pass" code.

    Hope this helps others...

  4. triefy
    Posted 4 years ago #

    Hey rcbaguio, I tried that as well and didn't have any luck. I ended up re-uploading the wp folders via FTP. Also changed the passwords.

Topic Closed

This topic has been closed to new replies.

About this Topic