WordPress.org

Support

Support » Multisite » [Resolved] Unable to login to sub blogs wp-admin

[Resolved] Unable to login to sub blogs wp-admin

  • I have 10 sub directory blogs
    it all started i moved to new host and 3.3.1 update.

    i can login only to main blog/site other blogs are visible to read to public [ http://mynation.net/abio/ ]

    but when i try to login to that blog it gives
    —————-
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    ——————–
    ERROR.

    when i try to go to sub blog wp-admin from main admin on URL it shows
    http://mynation.net/abio/wp-admin/ but display its blog page not admin panel page.

    anyone know the FIX….?

Viewing 15 replies - 1 through 15 (of 22 total)
  • When i imported from old site i changed old sites PATH [ /home/oldsite/public_html/ ] to new site PATH
    then
    I thought something wrong with webhost.
    so,
    I created test subdirectory blog http://mynation.net/test/ and its wp-admin also working fine

    only old Blogs wp-admin is not working

    …. so far exert on this issue ?

    your server is too slow .
    it does not opened any page with your link.
    i guess .htaccess may be anyhow modified or damaged

    your path for that subblog should like that

    “/home/oldsite/public_html/abio/”

    check for .htaccess file whether present or not
    if it is present in that path “/home/oldsite/public_html/abio/”
    edit and paste below code only. remove any other code if it is written

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Thank you very much for the reply.
    I have exactly same .htaccess

    i deleted http://mynation.net/test/ and other blogs are working
    eg:
    http://mynation.net/abio/
    http://mynation.net/docs/

    there is no physical directory called “/home/oldsite/public_html/abio/” so there is no .htaccess than public_html directory.

    one more thing i did was i just renamed http://mynation.net/abio/ into http://mynation.net/abio1/ and everything works fine [ now reverted back to actual blog name]

    i think wordpress is alergic to old path

    This is my .htaccess
    ————
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    ———–

    And this is my wp-config.php other than database settings

    define('DB_COLLATE', '');
    define('VHOST', 'no');
    
    $base = '/';
    
    define('DOMAIN_CURRENT_SITE', 'mynation.net' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    define( 'SUBDOMAIN_INSTALL', false );
    define('WP_HOME','http://mynation.net');
    define('WP_SITEURL','http://mynation.net');
    define( 'WP_CONTENT_URL', 'http://mynation.net/wp-content');
    define( 'WP_CONTENT_DIR', $_SERVER['DOCUMENT_ROOT'] . '/wp-content' );
    define( 'WP_PLUGIN_DIR', $_SERVER['DOCUMENT_ROOT'] . '/wp-content/plugins' );
    define( 'WP_PLUGIN_URL', 'http://mynation.net/wp-content/plugins');
    
    define('WP_POST_REVISIONS', false );
    define('CONCATENATE_SCRIPTS', false);
    define('EMPTY_TRASH_DAYS', 0 );
    define( "WP_USE_MULTIPLE_DB", false );
    define( 'NONCE_SALT', '[REMOVED]' );
    define('WP_ALLOW_MULTISITE', true);
    define('EMPTY_TRASH_DAYS', 0 );
    /* That's all, stop editing! Happy blogging. */
    
    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    sorry i type it in error.
    read it “/home/public_html/abio/” instead of “/home/oldsite/public_html/abio/”

    i think wordpress is alergic to old path

    i shifted my blog website to another webhost company without changing anything.

    Actually my webhost company(HOSTGATOR.COM) done all jobs for me without any charge. You should subscribe better webhost .

    my wp-config.php
    absolutely different from you

    for security reason i avoid posting it here

    Thank you Dr.Bappaditya Mukhopadhyay

    You can mail wp-config.php after trimming DB or any sensitive settings to email admin AT mynation.net

    i found out the problem.

    it was .htaccess given by wordpress by default

    and option of MULTISITE

    Here is my .htaccess

    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    and i also commented

    /**define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true ); */

    in wp-config.php

    and now MULTIsite is running perfectly with version 3.3.2 with these settings.

    Where on earth did you get that .htaccess? That should never work. You have multiple conflicting lines.

    but its works on my site.
    and with same .htaccess im running not only http://mynation.net and have another site http://manglorean.net which run multiple sites with same .htaccess file

    if you want i can give you FTP password, to see and beleive.

    Oh I believe you, I’m just very shocked.

    See this:

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

    Says ‘Anything that goes to domain.com/files/ gets redirected to domain.com/index.php’

    And THEN it says ‘If you’re coming from domain.com/wp-content/plugins/ and want to see domain.com/files/, use the ms-files code here…’

    Now the second half makes sense, if you have a plugin like TimThumb that parses things weirdly, but that first one… is weird and I can’t see how that shows ANY images, unless they’re all being handled by a plugin.

    Yes, that .htaccess is definitely wrong and definitely screwy. Your first .htaccess was a problem too, because you had this:

    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    That first rewrite rule was incorrect and in the wrong place.

    My advice to you is to clear out the .htaccess and let WordPress regenerate it properly. To do this, make the .htaccess writable and visit the main site’s settings->permalink page, and save the permalinks.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Unable to login to sub blogs wp-admin’ is closed to new replies.
Skip to toolbar