WordPress.org

Support

Support » Multisite » [Resolved] Unable to login to new site.

[Resolved] Unable to login to new site.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am still trying to debug the situation.
    I have attempted these steps still with no success.

    1) I edited my wp-config.php salt/hashes
    2) Dump your cache.
    3) Delete your cookies.
    4) Updated my .htaccess to

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) wp/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ wp/$2 [L]
    RewriteRule . index.php [L]

    5) Check that my wp-config.php defines multisite correctly.

    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('SUNRISE', 'on'); // Enable Domain Mapping JWL Nov 29 2012
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );

    Its still allows me to login to the admin for the main site and six other domains that I had running prior to the 3.5 update.

    Is this new site a mapped domain or a subdomain?

    Its a mapped domain, the site shows up fine like the rest. But the login just will not work. It wont even give me a error just a page refresh and thats it.

    Did it work as a subdomain?

    Sorry for the delayed response, I moved for the new year.
    When is was a subdomain it didn’t work also. It’s confusing because six other sites work fine with the exact same setup. Just this one that I just created won’t let me login to the admin.

    Okay. That’s your problem. If it doesn’t work as a sub domain, no way on the green earth will it work mapped 🙂

    Verify that the subdomain is set up correctly in DNS and on your server. If the subdomain doesn’t resolve to your server’s IP, that’s what’s going on.

    I tested DNS before posting to the forums, Its not that I am getting a 404 or any other type of error. The website loads and the login also load perfectly. Just when I type in the login and Pass and click login it just refreshes the login page. No error no nothing. Its resolving to the proper server and all my other sites are working fine. Just this certain one will not let me log in at all.

    Flush your browser cookies.

    Mika,
    Like I have said in my second post on this thread I have:

    1) I edited my wp-config.php salt/hashes
    2) Dump your cache.
    3) Delete your cookies.
    4) Updated my .htaccess to
    5) Check that my wp-config.php defines multisite correctly.

    I have also tried to log in using Safari ,Chrome , Firefox, Opera on both windows and mac computers.

    I have still yet been able to log into the new site.

    Obviously if it works for all other sites but this one, it’s not .htaccess or wp-config.

    But. Are you still testing on the mapped domain or the unmapped? This does matter, cause honestly, double-debugging both a possible goofed mapping AND a weird WP issue, isn’t work the headache 😉 Start from as step one as possible, then complicate matters.

    You said this happened on the subdomain as well. Does it happen on any others? Like can you make another subdomain and test that?

    Did you perhaps reuse an old subdomain?

    Testing on the mapped domain at the moment due to a non WordPress project is running. I am finishing off a project this week, I will have time after this weekend to dig into it. It doesn’t happen to any others sites, thats what’s been confusing me. I will create one next week and test that. I didn’t reuse a Subdomain. I will work on it Monday and see what I get. I will post here to let you know the result.

    I created another site, it worked properly. So I tested the original site again. Its now working properly. Don’t know what creating another site fixed, but they both are working fine.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Unable to login to new site.’ is closed to new replies.
Skip to toolbar