Support » Fixing WordPress » Unable to locate WordPress Plugin directory

  • I am ssing WP 2.7 installed on a Mac Mini.

    I have seen topics similar to this, but none with resolutions that have worked for me. When trying to use WP’s automatic upgrade plugin feature, I get the following error message

    Upgrade Plugin
    Unable to locate WordPress Plugin directory.
    Plugin upgrade Failed

    I have tried using a user account with home directory of WP’s root (on the Mac from which this is served, this is /Library/Webserver/Documents). I also have tried with a home directory of /Library/Webserver/Documents/blog (the WordPress address where WP is actually installed on my webserver). When testing with an ftp client (cyberduck), I drop directly into the folder specified as the user’s home.

    There is nothing non-standard about my installation, as far as I can tell – the plug-in directory resides in its default location, within wp-content.

    I do not encounter any authentication issues – just the error that the plugin directory cannot be found. Any help will be greatly appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The default folder for all plugins is /wp-content/plugins. If a plugin consists of only one file, you can just ftp it to the default folder. If a plugin consists of files and folders, you need to ftp the plugin folder recursively to the /plugins folder – meaning as a sub-folder to the plugins folder. Then go to your dashboard, plugins, and activate them.

    Thread Starter cwasmer


    I am able to install plugins using an FTP program or by downloading them directly onto my server and activating them via the plugin management admin page.

    What I want to be able to do, though, is use the WP 2.6+ feature of having WP upgrade my plugins “automatically.” I prefer the idea of logging into the blog, seeing that a new version of a plug-in is available, and then clicking on the “upgrade automatically” option so that the old one is deactivated, the new own downloaded and extracted in the correct place and then re-activated all with minimal effort on my part. However, when I try to use this feature, it reports an error that it cannot find the Plugins folder.

    I tried to correct this by creating a user that has a home directory that is the same as my blog’s home directory. When I use that user’s credentials with an FTP program, I log into my WordPress home – where my index.php file and .htaccess file is. However, when I try to auto-upgrade a plugin (or a theme, for that matter), using those same credentials, WordPress reports that it cannot find the Plugins folder (or, in the case of a theme, that it has simply failed to update the theme).

    So, perhaps I need to clarify my question – how do I get the auto-upgrade to work? What is WordPress looking for that it is not finding on my installation?

    Thanks –


    I am having this same issue and have searched these forums over and over for a result. Does anyone have a fix for this once and for all?

    WordPress 2.7

    The good news:
    issue is being discussed here.

    Bad news:
    no resolution so far.

    I’m quite new to WordPress and I am not quite sure if I “fully” understand your problem, and I do realize that this topic is half a year old,.. but I ran into a similar problem with 2.8.1 today.

    Tried to do the automatic update which forwarded me to a screen in which I had to put the server address and valid (ftp) user credentials. Being simple, as I am, I put in the server address and my ftp user credentials. Awesome as life is,.. it didn’t work and the response was that the plugin directory couldn’t be found. Google actions brought me no solutions or usable answers.

    Then both my braincells started working overtime and I tried to put in the address of the remote server, thinking as if I were the server. The address then would have to be “” instead of the URL of the website. This did work for me. Might not work for you,.. might not even haver been your problem,.. but I have been a happy person ever since I solved this and life makes sense to me again.

    Oh,.. and if for some seriously illogical reason the machine address of the server/computer is not “”, you might wanna try “localhost”. This solution might also solve (did for me) the issues I’ve seen countless people having with trying to install themes.

    If you had this same problem, and if this was a solution for you as well, you might wanna have a look in the upload directory (/wp-content/uploads). I managed to fill it up with my numerous attempts to install/upload new themes. You might want to empty it out a bit.

    I hope you or anyone else finds this information useful.

    hey, amazingfartface (the), your localhost magic helped!
    We had a WPMu installed in our server provider and moved everything to the amazon cloud, after that neither using IP or Domain as Host option worked, but your localhost idea worked like a charm.

    I wanted to thank you, so no one else can say the wp community is a thankless one!

    Here it goes: Thank you! 😀

    Hello everybody!

    I’m using WordPress 2.8.1 in ByetHost. I had the same problem but I solved it by adding the following code in my wp-config.php:

    if(is_admin()) {
    	add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    	define( 'FS_CHMOD_DIR', 0751 );

    I’ve just write a post in one of my blogs (a very new blog), but it’s in spanish. May be you will can understand or, at least, be useful. You can see it here:
    Solución a los problemas FTP en WordPress 2.8

    If you have any question, please leave it in my blog 😉

    Sorry for my English :S


    Ahhh, that’s good news! I am glad it helped you out, didn’t really expect anyone to notice my incoherent ramblings. But, your feedback is highly appreciated, and more important,… it’s a serious ego-boost for me 🙂

    Thank you!


    Hiya! I tried your code and it didn’t work for me, but I think we might not have had the same issue. Still good that you posted your message though, it will surely help someone out. Thanks.



    Thanks mcarretero, worked like a dream!

    Thanks mcarretero, that worked for me too…

    THANK YOU mcarretero, your solution also solved my problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Unable to locate WordPress Plugin directory’ is closed to new replies.